Closed Bug 671688 Opened 9 years ago Closed 9 years ago

nsAutoWindowStateHelper.cpp DOM notifications trigger "###!!! ASSERTION: Uh, inner window set as event target!: '!win || !win->IsInnerWindow()', file nsDOMEvent.cpp, line 878"

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 671160

People

(Reporter: dholbert, Unassigned)

References

Details

(Keywords: assertion)

Attachments

(1 file)

STEPS TO REPRODUCE:
 0. Have a local debug build.
 1. mkdir emptydir && ./dist/bin/firefox -profile emptydir -no-remote
   --> "default browser" dialog appears

ACTUAL RESULTS: Two instances of this assertion:
{
###!!! ASSERTION: Uh, inner window set as event target!: '!win || !win->IsInnerWindow()', file ../../../../mozilla/content/events/src/nsDOMEvent.cpp, line 878
}

One instance happens when the dialog appears, and the second happens when I dismiss the dialog.

From intercepting the assertions & looking up the stack, these assertions trace back to firing "DOMWillOpenModalDialog" and "DOMModalDialogClosed" events, from here:
> 51 nsAutoWindowStateHelper::nsAutoWindowStateHelper(nsIDOMWindow *aWindow)
> 52   : mWindow(aWindow),
> 53     mDefaultEnabled(DispatchCustomEvent("DOMWillOpenModalDialog"))
> 54 {
http://mxr.mozilla.org/mozilla-central/source/embedding/components/windowwatcher/src/nsAutoWindowStateHelper.cpp#51

and here:
> 62 nsAutoWindowStateHelper::~nsAutoWindowStateHelper()
> 63 {
[...]
> 71     DispatchCustomEvent("DOMModalDialogClosed");
http://mxr.mozilla.org/mozilla-central/source/embedding/components/windowwatcher/src/nsAutoWindowStateHelper.cpp#62
Adding dependency on bug 393707, which added the lines of code quoted in comment 0.  (Not sure if the assertion-failure traces back that far -- hence, I'm marking this as "depends on" that bug, rather than "blocking" that bug.)
Depends on: 393707
This is a dup of a bug which bz fixed yesterday or so...
Not sure if the patch landed yet.
Oh, awesome.

Sorry for filing the dupe -- I just relied on the new-bug-form's dupe suggestions (and that didn't turn up any actual matches), rather than doing an actual bug-search.

Duping.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671160
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.