Quick Filter bar results not visible when using High Contrast Black theme (port bug 575841 to aero)

RESOLVED FIXED in Thunderbird 9.0

Status

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: bjl, Assigned: Paenglab)

Tracking

({access})

Trunk
Thunderbird 9.0
x86
Windows 7
access

Thunderbird Tracking Flags

(thunderbird7+ fixed, thunderbird8 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18
Build ID: 20110614230723

Steps to reproduce:

Selected the High Contrast Theme
Used the TB5 Quick Filter bar to search


Actual results:

Text of results was the same colour as the background so not visible


Expected results:

The text and background should be a different colour. Preferably, for me, honouring the TB5 colour settings (which I have as white text on a black background).

The problem was raised and closed for TB3.1 in bug #575841 but was not actually fixed.

Comment 1

7 years ago
Confirmed on current 8.0a1 trunk build with Windows 7 and High Contrast #1, results list is shown yellow on solid white background. Apparently bug 575841 fixed qute for Windows XP/2000 but not the aero theme for Vista/Windows 7...
Status: UNCONFIRMED → NEW
Component: Search → Theme
Ever confirmed: true
Keywords: access
OS: Other → Windows 7
QA Contact: search → theme
Hardware: All → x86
Summary: Accessibility: Quick Filter bar results not visible when using High Contrast Black theme → Quick Filter bar results not visible when using High Contrast Black theme (port bug 575841 to aero)
Version: 5.0 → Trunk
(Assignee)

Comment 2

7 years ago
Created attachment 546608 [details] [diff] [review]
Use the tree decorations only with default themes

Instead of removing the definitions for all themes I added a media query for default theme. With this tree coloring still works for Aero and Basic but not for the others.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #546608 - Flags: review?(bwinton)

Comment 3

7 years ago
So, this would remove it for Windows Classic desktop theme as well? It has white background too, thus the color scheme should work here too. This may be overdoing it a bit, given the tree color being a good cue that the quick-filter is applied.
(Assignee)

Comment 4

7 years ago
I tried to add it to classic with -moz-windows-classic but this also applies for the contrast themes. So we have to drop it for classic :(. But have in mind on XP it's dropped for every theme.

If it's desired for XP default themes (Luna, Royal etc.) I can make a patch which copies the aero rules to XP theme.

If desired for non-default themes I can also use the Linux way with a colored outline around the tree.
(Reporter)

Comment 5

7 years ago
Thanks for picking up on this so fast guys. I reported the problem for the Win 7 High Contrast Black scheme since it shows the problem. But it's not actually the theme I use, I use a custom one.

I'm visually impaired and need to have white text on a black background. The Windows High Contrast Black theme achieves that but blends windows together and sets fonts to be bold. Very nasty.

What I actually do is take the Windows Classic theme and modify it to have white text on a black background. I also set 3d Objects to a darker grey. This makes windows stand out against each other.

(An aside. The problem with darkening the 3d objects renders the "To", "From", "Subject" tags on open mail windoes invisible (mid grey on mid grey). But I have reported that elsewhere. TB2 worked fine with this but this problem started with TB3. I don't know why the tags don't just use the text font colour).

Bruce
Comment on attachment 546608 [details] [diff] [review]
Use the tree decorations only with default themes

Blake asked me to steal this review.
Attachment #546608 - Flags: review?(bwinton) → review?(nisses.mail)
(Reporter)

Comment 7

7 years ago
Why don't you take the font and background colours from the TB options? In those options I've set white text on black.

It bugs me that the search, address book, and Lightning don't use the colurs I've ser for main TB window.

Comment 8

7 years ago
@BJ I use and require white text on black on the TB options. - Joshua
tracking-thunderbird7: --- → +
Comment on attachment 546608 [details] [diff] [review]
Use the tree decorations only with default themes

Tested on Aero and HC Black and works as expected.
Code looks good to go too!
Attachment #546608 - Flags: review?(nisses.mail) → review+
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
(Assignee)

Comment 10

7 years ago
Comment on attachment 546608 [details] [diff] [review]
Use the tree decorations only with default themes

I'm asking for approval‑comm‑aurora and approval‑comm‑beta because I think this improves the usability in high contrast themes and low risk to break something.
Attachment #546608 - Flags: approval-comm-beta?
Attachment #546608 - Flags: approval-comm-aurora?
Checked in: http://hg.mozilla.org/comm-central/rev/7d4febf4b827
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 9.0
Attachment #546608 - Flags: approval-comm-beta?
Attachment #546608 - Flags: approval-comm-beta+
Attachment #546608 - Flags: approval-comm-aurora?
Attachment #546608 - Flags: approval-comm-aurora+
Checked in:

http://hg.mozilla.org/releases/comm-aurora/rev/9adccbd3f5a3
http://hg.mozilla.org/releases/comm-beta/rev/be5cbc7dc169
status-thunderbird7: --- → fixed
status-thunderbird8: --- → fixed
You need to log in before you can comment on or make changes to this bug.