Hook libxpnet into linux installer

VERIFIED FIXED in mozilla0.9

Status

SeaMonkey
Installer
P3
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Samir Gehani, Assigned: Samir Gehani)

Tracking

Trunk
mozilla0.9
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [xpiprd] Fix in hand)

Attachments

(2 attachments)

Comment hidden (empty)
(Assignee)

Updated

17 years ago
Keywords: nsbeta1
Whiteboard: [xpiprd]
Target Milestone: --- → mozilla0.9
(Assignee)

Updated

17 years ago
Priority: -- → P3

Updated

17 years ago
QA Contact: gemal → gbush

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+
(Assignee)

Comment 1

17 years ago
*** Bug 55227 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

17 years ago
Created attachment 28662 [details] [diff] [review]
Proxy settings UI and functionality, HTTP support added via libxpnet use (FTP still supported).
(Assignee)

Comment 3

17 years ago
Created attachment 28663 [details] [diff] [review]
Revised patch includes the Makefile.in changes as well now.

Comment 4

17 years ago
r=dbragg
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: [xpiprd] → [xpiprd] Fix in hand

Comment 5

17 years ago
you're probably doing a whole lot more floating point math than you need to here:
+    diff_usecs = (aPost->tv_sec - aPre->tv_sec) * USECS_PER_SEC;
+    diff_usecs += (float)aPost->tv_usec - (float)aPre->tv_usec;
+    rate = ((float)(aBytes/KILOBYTE))/((float)(diff_usecs/USECS_PER_SEC));

if you think about it, you've got two integer constants in this last
calculation. Simplified, this is:

(aBytes/KILOBYTE) * (USECS_PER_SEC/diff_usecs)
which is actually the same as

(aBytes * USECS_PER_SEC) / (KILOBYTE * diff_usecs)
which is actually the same as

(aBytes/diff_usecs) / (USECS_PER_SEC / KILOBYTE)

and if you think about it that way, the compiler can do the work of
USECS_PER_SEC/KILOBYTE at compile time 
this could actually gain you some accuracy as well because your'e not dividing
or multiplying by very large numbers.. I love numerical math.

so if you switch to that, sr=alecf
(Assignee)

Comment 6

17 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
verified 
Status: RESOLVED → VERIFIED

Comment 8

17 years ago
*** Bug 79357 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.