Last Comment Bug 673003 - Handle \\\n in pymake
: Handle \\\n in pymake
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
:
Mentors:
: 585113 (view as bug list)
Depends on:
Blocks: 585015
  Show dependency treegraph
 
Reported: 2011-07-20 17:04 PDT by Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
Modified: 2011-07-21 11:36 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch? (1.14 KB, patch)
2011-07-20 17:04 PDT, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
ted: review+
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-07-20 17:04:25 PDT
Created attachment 547297 [details] [diff] [review]
Patch?

In http://hg.mozilla.org/users/bsmedberg_mozilla.com/pymake/rev/9de1d1f4e4b1 bsmedberg blocklisted '\\\n'.  I'm not a shell expert, but we can just strip that out, right?

It's going to be pretty annoying if we have to mash all of our pymake native commands onto one line.
Comment 1 Mitchell Field [:Mitch] 2011-07-21 04:05:03 PDT
*** Bug 585113 has been marked as a duplicate of this bug. ***
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-07-21 10:34:44 PDT
Comment on attachment 547297 [details] [diff] [review]
Patch?

Review of attachment 547297 [details] [diff] [review]:
-----------------------------------------------------------------

The code looks fine, but you really need to add some tests. r=me with tests.
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-07-21 11:36:33 PDT
http://hg.mozilla.org/users/bsmedberg_mozilla.com/pymake/rev/4a63f7834efe

Note You need to log in before you can comment on or make changes to this bug.