Last Comment Bug 675135 - should use -Fo instead of -o on MASM (LINK : fatal error LNK1181: cannot open input file 'methodjit/TrampolineMasmX64.obj')
: should use -Fo instead of -o on MASM (LINK : fatal error LNK1181: cannot open...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Windows Vista
: -- normal (vote)
: mozilla9
Assigned To: Makoto Kato [:m_kato]
:
Mentors:
: 680477 (view as bug list)
Depends on:
Blocks: tracking_win64 support-win64 678867 680395
  Show dependency treegraph
 
Reported: 2011-07-28 21:18 PDT by Makoto Kato [:m_kato]
Modified: 2011-08-25 18:44 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.55 KB, patch)
2011-07-28 21:19 PDT, Makoto Kato [:m_kato]
ted: review+
Details | Diff | Splinter Review
fix v2 (2.60 KB, patch)
2011-08-18 05:43 PDT, Makoto Kato [:m_kato]
ted: review+
Details | Diff | Splinter Review

Description Makoto Kato [:m_kato] 2011-07-28 21:18:15 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1311893165.1311904617.14231.gz

ml64.exe -o TrampolineMasmX64.obj  -c /e/builds/moz2_slave/m-cen-w64/build/js/src/methodjit/TrampolineMasmX64.asm
MASM : warning A4018:invalid command-line option : -o
 Assembling: e:/builds/moz2_slave/m-cen-w64/build/js/src/methodjit/TrampolineMasmX64.asm
Comment 1 Makoto Kato [:m_kato] 2011-07-28 21:19:42 PDT
Created attachment 549300 [details] [diff] [review]
fix
Comment 2 Makoto Kato [:m_kato] 2011-08-18 05:43:21 PDT
Created attachment 554041 [details] [diff] [review]
fix v2

When I wrote previous fix, yasm didn't works due to bug 675568.  This fix considers that AS is yasm for libjpeg-turbo.
Comment 3 Armen Zambrano [:armenzg] - Engineering productivity 2011-08-18 11:56:04 PDT
We need to fix this to get the builds green again.

Adjusting summary to help tbpl match this bug.

ml64.exe -o methodjit/TrampolineMasmX64.obj  -c /e/builds/moz2_slave/m-cen-w64/build/js/src/methodjit/TrampolineMasmX64.asm
MASM : warning A4018:invalid command-line option : -o
 Assembling: e:/builds/moz2_slave/m-cen-w64/build/js/src/methodjit/TrampolineMasmX64.asm
ml64.exe -o jswin64.obj  -c /e/builds/moz2_slave/m-cen-w64/build/js/src/jswin64.asm
MASM : warning A4018:invalid command-line option : -o
 Assembling: e:/builds/moz2_slave/m-cen-w64/build/js/src/jswin64.asm
rm -f js_static.lib js_static.lib.desc
c:/mozilla-build/python/python2.6.exe /e/builds/moz2_slave/m-cen-w64/build/js/src/config/pythonpath.py -I./config /e/builds/moz2_slave/m-cen-w64/build/js/src/config/expandlibs_exec.py --extract -- lib -NOLOGO -OUT:"js_static.lib" jsalloc.obj jsanalyze.obj jsapi.obj jsarena.obj jsarray.obj jsatom.obj jsbool.obj jsclone.obj jscntxt.obj jscompartment.obj jsdate.obj jsdbgapi.obj jsdhash.obj jsdtoa.obj jsemit.obj jsexn.obj jsfriendapi.obj jsfun.obj jsgc.obj jsgcmark.obj jsgcchunk.obj jsgcstats.obj jscrashreport.obj jshash.obj jsinterp.obj jsinvoke.obj jsiter.obj jslock.obj jslog2.obj jsmath.obj jsnativestack.obj jsnum.obj jsobj.obj json.obj jsonparser.obj jsopcode.obj jsparse.obj jsproxy.obj jsprf.obj jsprobes.obj jspropertycache.obj jspropertytree.obj jsreflect.obj jsregexp.obj jsscan.obj jsscope.obj jsscript.obj jsstr.obj jstypedarray.obj jsutil.obj jswatchpoint.obj jsweakmap.obj jswrapper.obj jsxdrapi.obj jsxml.obj prmjtime.obj sharkctl.obj vm/Debugger.obj vm/GlobalObject.obj vm/Stack.obj vm/String.obj frontend/ParseMaps.obj vm/Unicode.obj jstracer.obj nanojit/Assembler.obj nanojit/Allocator.obj nanojit/CodeAlloc.obj nanojit/Containers.obj nanojit/Fragmento.obj nanojit/LIR.obj nanojit/njconfig.obj nanojit/RegAlloc.obj nanojit/avmplus.obj nanojit/NativeX64.obj jsbuiltins.obj nanojit/VMPI.obj tracejit/Writer.obj methodjit/MethodJIT.obj methodjit/StubCalls.obj methodjit/Compiler.obj methodjit/FrameState.obj methodjit/FastArithmetic.obj methodjit/FastOps.obj methodjit/StubCompiler.obj methodjit/MonoIC.obj methodjit/PolyIC.obj methodjit/ImmutableSync.obj methodjit/InvokeHelpers.obj methodjit/Retcon.obj methodjit/TrampolineCompiler.obj v8-dtoa/checks.obj v8-dtoa/conversions.obj v8-dtoa/diy-fp.obj v8-dtoa/v8-dtoa.obj v8-dtoa/fast-dtoa.obj v8-dtoa/platform.obj v8-dtoa/utils.obj Assertions.obj ExecutableAllocatorPosix.obj ExecutableAllocatorWin.obj ExecutableAllocatorOS2.obj ExecutableAllocator.obj ARMAssembler.obj Logging.obj MacroAssemblerARM.obj MacroAssemblerX86Common.obj OSAllocatorOS2.obj OSAllocatorPosix.obj OSAllocatorWin.obj PageBlock.obj YarrInterpreter.obj YarrJIT.obj YarrPattern.obj YarrSyntaxChecker.obj ctypes/CTypes.obj ctypes/Library.obj perf/jsperf.obj perf/pm_stub.obj methodjit/TrampolineMasmX64.obj jswin64.obj  ctypes/libffi/.libs/libffi.lib 
Microsoft (R) Macro Assembler (x64) Version 9.00.30729.01
Copyright (C) Microsoft Corporation.  All rights reserved.

Microsoft (R) Macro Assembler (x64) Version 9.00.30729.01
Copyright (C) Microsoft Corporation.  All rights reserved.

LINK : fatal error LNK1181: cannot open input file 'methodjit/TrampolineMasmX64.obj'
make[5]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox/js/src'
make[4]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox'
make[3]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox'
make[2]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox'
make[1]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build'
make[5]: *** [js_static.lib] Error 157
make[4]: *** [libs_tier_js] Error 2
make[3]: *** [tier_js] Error 2
make[2]: *** [default] Error 2
make[1]: *** [realbuild] Error 2
make: *** [profiledbuild] Error 2
Comment 4 Makoto Kato [:m_kato] 2011-08-19 10:24:28 PDT
*** Bug 680477 has been marked as a duplicate of this bug. ***
Comment 5 alanjstr 2011-08-19 11:27:12 PDT
Can someone help me understand why 680477 is marked as a duplicate?  x64 builds were being produced until 8/15, but this bug is from 7/28.
Comment 6 Makoto Kato [:m_kato] 2011-08-19 11:30:51 PDT
(In reply to alanjstr from comment #5)
> Can someone help me understand why 680477 is marked as a duplicate?  x64
> builds were being produced until 8/15, but this bug is from 7/28.

To land bug 678867 is causing bustage for Win64 build.  But it can fix by this bug.
Comment 8 Ed Morley [:emorley] 2011-08-25 18:44:05 PDT
http://hg.mozilla.org/mozilla-central/rev/b370f47da297

Note You need to log in before you can comment on or make changes to this bug.