clicking List-Reply fails: tempID.email is null

RESOLVED FIXED in Thunderbird 9.0

Status

defect
--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: wolfiR, Assigned: Bienvenu)

Tracking

({regression})

Trunk
Thunderbird 9.0
All
Linux
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird6-, thunderbird7+ fixed, thunderbird8 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

8 years ago
This is THUNDERBIRD_6_0b2_RELEASE.

Trying to reply to a list email with reply-to-list fails with the following error in the error console:

Fehler: tempID.email is null
Quelldatei: chrome://messenger/content/mailCommands.js
Zeile: 112

        if (deliveredTos[i].indexOf(tempID.email.toLowerCase()) != -1) {
          hintForIdentity = tempID.email;
          break;
        }
Assignee

Comment 1

8 years ago
You have an identity without an e-mail address - a work around for this bug is to fix that in your profile.
Reporter

Comment 2

8 years ago
Hmm, could be.
But then something else is broken.

This is the link I used recently to subscribe a newgroup. This was successful but the whole account misses quite some information like an email address.
news://news.mozdev.org/public.mozdev.enigmail

Just clicking a link like that must not break Thunderbird's core functions.
Assignee

Comment 3

8 years ago
yeah, clicking on a newsgroup link is what caused the issue for me too, iirc. I'm not saying it's not a bug; I was just explaining how you could work around it. Sorry if that wasn't clear.
I have the same bug on Thunderbird 5 for regular mailing lists (received via IMPA, not NNTP). all my accounts (newsgroup accounts included) have an email address defined.
I'm guessing this is a regression or something shown up by bug 461669
Blocks: 461669
Keywords: regression

Comment 6

8 years ago
Thunderbird 5 (Linux) works, Thunderbird 6.0 beta Windows ignores the Reply to List button on some list mails, other lists work.

Mails with the header: List-Post: <mailto:amavis-users@amavis.org> FAIL.
Mails with the header: List-Post: <mailto:ivtv-devel@ivtvdriver.org> SUCCEED
Mails with Extended Header:
List-Post: <http://groups.google.com/group/issh/post?hl=en_US>, <mailto:issh@googlegroups.com>  SUCCEED
Mails with the header: List-Post: <mailto:opensuse@opensuse.org> FAIL

All of these examples succeed on Linux Tbird 5.
Assignee: nobody → dbienvenu
Assignee

Comment 7

8 years ago
Posted patch proposed fixSplinter Review
SeaMonkey uses a try catch so they don't have this problem...
Attachment #560409 - Flags: review?(squibblyflabbetydoo)
Duplicate of this bug: 672965
Attachment #560409 - Attachment is patch: true
Attachment #560409 - Flags: review?(squibblyflabbetydoo) → review+
Assignee

Comment 9

8 years ago
http://hg.mozilla.org/comm-central/rev/fb476890accb - fixed on trunk.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Assignee

Updated

8 years ago
Attachment #560409 - Flags: approval-comm-beta?
Attachment #560409 - Flags: approval-comm-aurora?
Attachment #560409 - Flags: approval-comm-beta?
Attachment #560409 - Flags: approval-comm-beta+
Attachment #560409 - Flags: approval-comm-aurora?
Attachment #560409 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.