The default bug view has changed. See this FAQ.

[OGL] GL Reftest on Android

RESOLVED FIXED in mozilla9

Status

()

Core
Graphics
RESOLVED FIXED
6 years ago
a year ago

People

(Reporter: BenWa, Assigned: BenWa)

Tracking

(Depends on: 2 bugs)

unspecified
mozilla9
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

41.32 KB, patch
Joe Drew (not getting mail)
: review+
Details | Diff | Splinter Review
(Assignee)

Description

6 years ago
We need to get test coverage for opengl reftest on android.
(Assignee)

Comment 1

6 years ago
Trying a test on android to get an idea for what state we are at for reftest + talos:
http://tbpl.allizom.org/?tree=Try&usebuildbot=1&rev=23fa4d835b88
(Assignee)

Updated

6 years ago
Depends on: 683195
(Assignee)

Updated

6 years ago
Depends on: 683198
(Assignee)

Updated

6 years ago
Depends on: 683199
(Assignee)

Comment 2

6 years ago
We also made some test to see where we stand for talos. We didn't notice any significant regression. Some results were +2% which are on the high end of the regression.

The results are suspicious so I ran a patch to force a regression to make sure the test were being executed properly. This appears to be the case as test show a ~270% regression on tp4mobile no chrome and fennecbench zoom. I'm not sure why we didn't see a regression with tp4 mobile.
http://hg.mozilla.org/try/rev/4cca6e24dd2d

Everything looks normal with enable OGL and no regression being forced:
http://hg.mozilla.org/try/rev/1d364e6248ac

http://graphs-new.mozilla.org/graph.html#tests=[[84,23,20],[85,23,20],[70,23,20],[69,23,20]]&sel=none&displayrange=30&datatype=running
(If viewing >30 days from now change the displayrange)
(Assignee)

Comment 3

6 years ago
Ran into remote-reftest misreporting success (doesn't block this):
https://bugzilla.mozilla.org/show_bug.cgi?id=685360
(Assignee)

Updated

6 years ago
Depends on: 685694
(Assignee)

Comment 4

6 years ago
Created attachment 560996 [details] [diff] [review]
Flag Failures

For now I flagged all the failing test so that we can enable test coverage for OGL. Of importance is that all canvas/css-gradients/image-element/svg are disable for now.

We will work towards supporting all android reftest but for the time being I suggest that we ignore these test for this configuration and start automated testing to prevent further regressions.

Follow up task will be to remove all occurrences of |Android&&layersOpenGL| in **/reftest.list files.
(Assignee)

Updated

6 years ago
Attachment #560996 - Flags: review?(joe)
Comment on attachment 560996 [details] [diff] [review]
Flag Failures

Review of attachment 560996 [details] [diff] [review]:
-----------------------------------------------------------------

We should definitely have at least two followup bugs; I don't think we can release with any skip-if(Android&&layersOpenGL), especially not if they are skipped because they crash, but we should also try to fix all the failures before releasing.
Attachment #560996 - Flags: review?(joe) → review+
https://hg.mozilla.org/mozilla-central/rev/5edba813e1e6
Assignee: ajuma → bgirard
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla9
(Assignee)

Updated

6 years ago
Depends on: 691349
(Assignee)

Updated

6 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I presume those follow-up bugs were filed?
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.