New webapp status should obey WEBAPPS_RESTRICTED

RESOLVED FIXED in 6.2.0

Status

RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: jbalogh, Assigned: gkoberger)

Tracking

6.2.0
x86
Mac OS X

Details

(Whiteboard: [apps])

(Reporter)

Description

8 years ago
https://github.com/jbalogh/zamboni/commit/04d1c19 

status = amo.STATUS_PENDING if settings.WEBAPPS_RESTRICTED else amo.STATUS_LITE

Here's what I'm thinking will work for the statuses:

There's two states for the webapp queue: pre-release (RESTRICTED = True) and post-release (RESTRICTED = False).

When RESTRICTED = True there are two possible statuses: PUBLIC and PENDING. Our normal status checks will prevent PENDING apps from showing up on the site.

When RESTRICTED = False there are three possible statuses: PUBLIC, LITE, DISABLED. As mentioned in bug 675354, new webapps will be listed on the site without any review. Setting these to LITE lets us show them on the site while remembering that they haven't been reviewed.

(I guess DISABLED is possible for RESTRICTED = True too.)
(Reporter)

Updated

8 years ago
Whiteboard: [apps]
Assignee: kumar.mcmillan → nobody
Assignee: nobody → gkoberger
(Reporter)

Updated

7 years ago
Duplicate of this bug: 678076
(Assignee)

Comment 2

7 years ago
http://github.com/jbalogh/zamboni/commit/78220b2
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.