Last Comment Bug 677027 - Implement conditional forward button for gnomestripe
: Implement conditional forward button for gnomestripe
Status: RESOLVED FIXED
: ux-minimalism
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All Linux
: -- enhancement (vote)
: Firefox 10
Assigned To: Dão Gottwald [:dao]
:
:
Mentors:
Depends on: 681480 682536 694084
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-06 07:13 PDT by Dão Gottwald [:dao]
Modified: 2011-10-12 11:33 PDT (History)
11 users (show)
dao+bmo: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.40 KB, patch)
2011-08-06 07:13 PDT, Dão Gottwald [:dao]
shorlander: review+
Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2011-08-06 07:13:20 PDT
Created attachment 551255 [details] [diff] [review]
patch

I was just playing with this and it works surprisingly well even without the keyhole, so I figured I may as well put it up for review.

The button shifts the location bar when it appears, as does the keyhole-dependent implementation for windows and mac in bug 674744. I would normally be concerned about this kind of movement being distracting, but it turns out this isn't a big deal here, since it happens while the page is also changing.
Comment 1 Dão Gottwald [:dao] 2011-08-06 07:17:32 PDT
pushed to ux
Comment 2 Stephen Horlander [:shorlander] 2011-08-22 11:12:06 PDT
Comment on attachment 551255 [details] [diff] [review]
patch

Review of attachment 551255 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good although 300 or 250ms feels a little snappier to me.

I guess there is no way with this approach to avoid shifting the searchBar and the locationBar? Right now that is the only jarring part.

Something Jared and I were talking about in regards to bug 674744 was minimizing the shifting as much as possible. Ideally only the locationBar would slide over to keep the transition as subtle as possible.
Comment 3 Dão Gottwald [:dao] 2011-08-22 11:15:17 PDT
> I guess there is no way with this approach to avoid shifting the searchBar
> and the locationBar? Right now that is the only jarring part.

Well, there is a way: Let the back button consume more space and shrink that to make room for the forward button. I'm not sure at all if that's a better approach, though.
Comment 4 Stephen Horlander [:shorlander] 2011-08-22 11:16:56 PDT
(In reply to Dão Gottwald [:dao] from comment #3)
> I'm not sure at all if that's a better approach, though.

Probably not :)
Comment 5 Mounir Lamouri (:mounir) 2011-08-23 01:30:55 PDT
http://hg.mozilla.org/mozilla-central/rev/0812db89f2f2
Comment 6 Mounir Lamouri (:mounir) 2011-08-23 03:53:57 PDT
Why do we *can't*? test this?
Comment 7 Siddhartha Dugar [:sdrocking] 2011-08-23 04:21:38 PDT
Why do we just have this for Linux and not on all platforms? (Bug 674744)
Comment 8 Dão Gottwald [:dao] 2011-08-23 07:34:10 PDT
(In reply to Mounir Lamouri (:volkmar) from comment #6)
> Why do we *can't*? test this?

This code is doing nothing that we'd need or want to test.
Comment 9 Matthew Turnbull [Bluefang] 2011-08-25 17:15:49 PDT
(In reply to Dão Gottwald [:dao] from comment #0)
> The button shifts the location bar when it appears, as does the
> keyhole-dependent implementation for windows and mac in bug 674744. I would
> normally be concerned about this kind of movement being distracting, but it
> turns out this isn't a big deal here, since it happens while the page is
> also changing.



Just for the record, this *is* distracting, and can be somewhat problematic.

* Every time it pops in or out, it draws my attention to it. As such, it's constantly drawing my attention away from the content area, which, for a browser, seems counter productive. Yes, the page content is changing, but it's still disruptive to the browsing 'flow', as you (I) now refocus/context-switch twice instead of maybe once.

* When I open a blank tab to enter something in the location bar, I usually have already focused on the location bar (or I'm already in the process of doing so). So having it jump to the left is, again, disruptive.

* If, say, you've gone back a few pages to check something, then want to go back to the most recent page, click-spaming the forward button will often result in clicking the identity button (or, in my case, reload).

I can see how this makes sense on a mobile device, but is this necessary, or even useful, on a desktop?
Comment 10 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-08-31 01:32:36 PDT
FWIW, this is rather distracting when reading a Web forum where you open a thread (forward button goes away), go back to list of threads (forward button comes back), open the next thread (forward button goes away), etc.
Comment 11 Dão Gottwald [:dao] 2011-09-27 03:47:25 PDT
Backed out in preparation for the aurora merge, since the followup bugs didn't make it (blocked by bug 682534).
Comment 13 Matt Brubeck (:mbrubeck) 2011-10-10 11:15:41 PDT
Re-landed in Firefox 10:
https://hg.mozilla.org/mozilla-central/rev/80be49be4394

Note You need to log in before you can comment on or make changes to this bug.