Closed Bug 680446 Opened 8 years ago Closed 8 years ago

Printing more than one e-mails at the same time reduces the message content. Multiple selection prints only summary.

Categories

(Thunderbird :: General, defect)

6 Branch
x86
All
defect
Not set

Tracking

(thunderbird7+ fixed, thunderbird8+ fixed)

RESOLVED FIXED
Thunderbird 9.0
Tracking Status
thunderbird7 + fixed
thunderbird8 + fixed

People

(Reporter: a0005408, Assigned: standard8)

References

(Blocks 1 open bug, )

Details

(Keywords: regression, Whiteboard: [gs])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

Start TB in -safe-mode.
In the message preview window I select more than one email.
Right click on them, "Print...".



Actual results:

It opens the printer's preview window of my printer driver.
At the end of each message you see .e.g.:

"Dies ist der Beitrag..."
or
"D..."


Expected results:

TB  should list the complete message body (as in vers. 3 and 5) of all messages.
But it shows only a very small part of each message.

Workaround: printing every mail separately.
approximately 20 reports in http://getsatisfaction.com/mozilla_messaging/topics/printing_multiple_messages
Blocks: 611458
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Summary: Printing more than one e-mails at the same time reduces the message content → Printing more than one e-mails at the same time reduces the message content. Multiple selection prints only summary.
Whiteboard: [gs]
Duplicate of this bug: 680889
Setting mail.operate_on_msgs_in_collapsed_threads to false reverts to original behavior.
What was the original behavior? If you selected multiple mails it would print them all together?

What I could do is print the *thread* summary, but when multiple messages across threads are selected, print them as individual messages. That still wouldn't solve the case of multiple messages in the same thread selected.

Blake, thoughts on this?
I was thinking offer both in context menu
 Print Summary
and
 Print Messages

but then File | Print  is stuck in one mode.  Unless the Print dialog itself offered a choice.
There is a related issue http://getsatisfaction.com/mozilla_messaging/topics/batch_printing_of_emails#reply_6452321 (which I cannot confirm, but I've seen two people post this) that "I am given a print dialog box for every selected email, rather than one box that will print the selected range for ALL the selected emails."
I can confirm comment 6 - selecting multiple messages with collapsed off now causes multiple print dialogs. So, a solution is also needed for this issue, or backout of bug 611458 is needed.

http://gsfn.us/t/2fg3e now has 70+ following after updating with past 2-3 weeks of activity.
Assignee: nobody → mbanner
I fixed this in the first place so that people could use File > Print to print the conversation view (JB had pointed that out). Do you plan on reverting to the old behavior?
(In reply to Jonathan Protzenko [:protz] from comment #8)
> I fixed this in the first place so that people could use File > Print to
> print the conversation view (JB had pointed that out). Do you plan on
> reverting to the old behavior?

At the moment yes we are considering backout, though I'll confirm with JB first.

We need to find a better solution to allow both methods of printing, as it appears folks do want to be able to print in the old style of multiple emails.
This backs out the non-css parts of bug 611458, note that http://hg.mozilla.org/comm-central/rev/72f40b7e9357 had already backed out some of the patch.

As already mentioned, this is because printing multiple emails at the same time is considered a necessary function in core Thunderbird.

I think it is fine to use the css parts in.

Conversations will need to either inject its own controllers into the controller tree, or provide some other way of overriding the option, or potentially supplying its own menu options.
Attachment #560468 - Flags: review?(bwinton)
Comment on attachment 560468 [details] [diff] [review]
Backout some of bug 611458

Review of attachment 560468 [details] [diff] [review]:
-----------------------------------------------------------------

Well, that took a while, but this patch looks good to me, and even seems to fix the bug.  ;)

r=me.
Attachment #560468 - Flags: review?(bwinton) → review+
Checked in:

http://hg.mozilla.org/comm-central/rev/3450e93def8c
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 9.0
Attachment #560468 - Flags: approval-comm-beta+
Attachment #560468 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.