Images and some form items disappear after load, leaving window unresponsive. [Flycast]

VERIFIED WORKSFORME

Status

()

Core
DOM: Core & HTML
--
critical
VERIFIED WORKSFORME
18 years ago
6 years ago

People

(Reporter: hirata masakazu, Assigned: jst)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
MTrunk 2001020708.
Goto URL above.
Images start to load but disappear after load seems complete.
Sometimes, form textarea remains, sometimes there is background only.
Afterwards, the window is unresponsive to Drag and Drop of a link from another
window.
(Reporter)

Comment 1

18 years ago
Actually, text contents disappear, too.
(Reporter)

Comment 2

18 years ago
*** Bug 68111 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

18 years ago
All/All from bug 68111:
2001020721 trunk linux
20010206xx trunk win98

go to one of keenspot.com comics site eg:

http://www.elflife.com/
http://www.gpf-comics.com/
http://www.coolcatstudio.com/
http://www.clanofthecats.com/

The page loads and at the end, the content disappears.
I suspect it has something to do with iframe because sometimes the content
disappears and is replace by an ad which is in an iframe.
OS: Mac System 9.x → All
Hardware: Macintosh → All

Comment 4

18 years ago
*** Bug 68114 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
Another site with the same behavior:
http://www.jc-news.com/pc

Comment 6

18 years ago
On linux build 2001020712 the page on http://www.sinfest.net looks fine
but I have the same problem on these pages instead:

http://www.3ivx.com/index.html
http://www.dlink.com/products/

And after having been on the dlink page mozilla is very likely to crash. Happend
three times now in different places after I have viewed the dlink page. So this
is the third time I try to write this comment :-)

Comment 7

18 years ago
I have experienced this problem with http://www.newyorkmag.com/ using 2001020715
on Mac OS 9.1.

It seems like the source of the problem is the Flycast ad code, which involves
Javascript. The page loads properly when Javascript is turned off or when the
source is loaded without the Flycast ad code.

I also experienced a crash from this bug on another site (inside a Web mail
site, so I can't provide a link)

Comment 8

18 years ago
*** Bug 68252 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
*** Bug 68285 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Summary: Images and some form items disappear after load, leaving window unresponsive. → Images and some form items disappear after load, leaving window unresponsive. [Flycast]

Comment 10

18 years ago
modifying summary

Comment 11

18 years ago
Possible dup of bug 66034, "Content in Mozilla disappears seemingly at random", 
which is marked as "critical for 0.8".

Comment 12

18 years ago
No, this is definately related to the Flycast js stuff.
All dups have that add in common, while that is not an ingredience in bug 66034.
In this bug - 68052 - there is no need to swith back/forth between pages - they
start to render fine - then vanish when the flycast stuff is read in.

Comment 13

18 years ago
can we mark this critical for 0.8 then?  it makes the browser useless for a
significant percentage of the websites out there.
Bug 68350 might be a duplicate of this one. That bug is caused by the javascript
writing a <script> tag and the output of the second script replaces the current
page instead of being appended to it. I have written a testcase for 68350.
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=24958
This is the test that I originally created for 68350. 
After looking at and playing with the flycast script some more I'm almost
positive that this is the same bug. From building the test case it seems that
the bug is triggered by a javascript that writes one or more <SCRIPT> tags to
the document including a second level of javascript that tries to append to the
document and ends up being the only thing displayed. 

Comment 16

18 years ago
DOM Level 0 for starters - doesn't seem to be a layout bug
Assignee: karnaze → jst
Component: Layout → DOM Level 0
Keywords: testcase
QA Contact: petersen → desale
(Assignee)

Comment 17

18 years ago
Worksforme in todays build.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 18

18 years ago
Verifying WFM on linux 2001-021006. Tested these dups, all now load fine:
http://www.sinfest.net
http://www.elflife.com/
http://www.gpf-comics.com/
http://www.jc-news.com/pc
http://www.3ivx.com/index.html
http://www.dlink.com/products/

This one never finished loading, but no content vanish:
http://www.jc-news.com/pc/

Comment 19

18 years ago
*** Bug 68494 has been marked as a duplicate of this bug. ***
*** Bug 68350 has been marked as a duplicate of this bug. ***

Comment 21

18 years ago
*** Bug 68559 has been marked as a duplicate of this bug. ***

Comment 22

18 years ago
Works for me too. Verified with 2001-02-13-09.
Status: RESOLVED → VERIFIED

Comment 23

6 years ago
Having this problem again specifically on this URL: http://www.guitarcenter.com/T-Rex-Engineering-Room-Mate-Tube-Reverb-Guitar-Pedal-151087-i1322356.gc

seems to be universal problem when clicking on any item in the guitarcenter website.  

I am running the latest nightly build, downloaded a few minutes ago in an attempt to resolve.
You need to log in before you can comment on or make changes to this bug.