Include new RealPlayer custom build for the Mac in next release

VERIFIED FIXED in mozilla0.9.1

Status

SeaMonkey
Build Config
P1
major
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Todd Pringle, Assigned: Samir Gehani)

Tracking

Trunk
mozilla0.9.1
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: smartupdate Fix in hand)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Filing this bug in Bugzilla in order to keep Real folks in the loop, with Real's
permission.  Do not use dates in this bug.  

Real will provide a custom Macintosh build of RealPlayer 8 for inclusion in our
next release.  We do *not* have this yet, so I'm assigning the bug to myself
until I have the bits.
(Reporter)

Comment 1

17 years ago
Changing QA Contact to Grace Bush.  Nominating nsbeta1.
Keywords: nsbeta1
QA Contact: granrose → gbush
(Assignee)

Comment 2

17 years ago
Are they providing their own installer which we will have to launch or will we
just be given bits and deliver a zippy (the latter is preferred personally if
I'm signed up for this).  The UI flow for the former will not be smooth.

Comment 3

17 years ago
Thank you so much for bringing this up, Samir. Adding RealPLayer8 to Communicator 
4.76 was a real pain, because of the contractual agreement we signed with 
RealNetworks to ship _their_ installer. Let's try to make things different for NS 
6.
By writting this, I'm hoping to catch Marketing, Legal and Real's attention :-)
(Reporter)

Comment 4

17 years ago
Reassigning to jj and sending bits separately via email.  Can we get this in
soon so that we can begin testing?
Assignee: tpringle → jj

Comment 5

17 years ago
How "soon" should that be?
Some technical packaging issues should be resolved before I can proceed with the 
daily packaging automation changes.
Todd & Samir are working on this right now and a status update will follow in 
terms of ETA.
Status: NEW → ASSIGNED
adding realplayer keywords and smartupdate in status whiteboard
Keywords: realplayer
Whiteboard: smartupdate
(Reporter)

Comment 7

17 years ago
*** Bug 56204 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
setting TVF for Future so this no longer shows up as "untargetted".
Target Milestone: --- → Future
(Assignee)

Comment 9

17 years ago
This needs to happen for mozilla0.9.1.  JJ has run through the issues and 
emailed us an evaluation.  JJ and I will work together on this bug upon his 
return.  Leaving assigned to him but setting milestone to mozilla0.9.1 so it 
doesn't fall off the radar.  

Todd, please get this approved to nsbeta1+ soon so it doesn't fall off.  Thanks.
Target Milestone: Future → mozilla0.9.1
(Reporter)

Comment 10

17 years ago
John, Leaf,

I don't know who triages your bugs and marks nsbeta1's + or -, but I'm going to
go ahead and mark this nsbeta1+.  If that's a problem, please let me know so
that we can discuss.
Keywords: nsbeta1 → nsbeta1+
(Assignee)

Comment 11

17 years ago
*** Bug 77303 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 12

17 years ago
jj, we really need to get this in quickly so that QA can get some testing in
before beta - how's it coming?
(Assignee)

Comment 13

17 years ago
JJ was scheduled to return from vacation today and may be inundated with
bugmail.  Once he has room to breathe again we'll be working on this together. 
Thanks for your patience while he readjusts.  

Comment 14

17 years ago
actually, he doesn't get back til tomorrow (5/2).  I wouldn't expect any action
on this bug til sometime next week at the earliest.

Updated

17 years ago
Severity: normal → major
Priority: -- → P1

Comment 15

17 years ago
Silent installer chacked in here:
  ns/shelf/macppc/realplayer/RealPlayer_for_NS_Installer

Build packaging automation updated to move this file under dist viewer so that it 
can be processed by pkgcp.pl

Final steps consist in adding a [RealPlayer] section in packages-mac (in ns), and 
create a RealPlayer.jst under ns/xpinstall/packager/mac/

Samir, since you're going to take care of these, I can either reassign this bug 
to you, or you can simply mark it fixed when you're done. Up to you.

Comment 16

17 years ago
thanks, jj!  reassigning to sgehani to make bug triaging easier.
Assignee: jj → sgehani
Status: ASSIGNED → NEW
(Assignee)

Comment 17

17 years ago
Created attachment 33821 [details] [diff] [review]
Patch to generate realplayer.xpi
(Assignee)

Comment 18

17 years ago
ssu, please r.
dveditz, please sr.

Thanks.
Status: NEW → ASSIGNED
Whiteboard: smartupdate → smartupdate Fix in hand
(Assignee)

Comment 19

17 years ago
Reviewers,
In case you're wondering where the equivalent of a makexpi() call is: jj's build
scripts detect new sections in the packages-mac manifest and automatically
generate a zippy for all sections (and generate an install.js based on the
<component>.jst install script template).

Comment 20

17 years ago
I've noticed that realplayer is in the "typical" section.  This is not the case 
for the windows platform.  If this is indeed correct for the mac, then r=ssu.
(Assignee)

Comment 21

17 years ago
Sean,
Todd mentioned that it should be in all three setup types.  Thanks for the review.
(Reporter)

Comment 22

17 years ago
Samir, actually, no I don't think I ever said that - maybe you're thinking of
Flash or something else.  In any event, we should do as we do with windows -
full and custom only.
(Assignee)

Comment 23

17 years ago
Hmmm, brainfart (I was remembering teh discussion about Flash for Linux).  I
updated my tree to not include Real in the Recommended Install.  Thanks for
clarifying, Todd.
Technically need an e-mail cc:'d to reviewers-internal@netscape for a 
commercial sr= request. Yes, it (and equivalent reviewers@mozilla.org) is a 
mostly write-only address, but it is useful on occasion.

wierd tab/space thing going on in realplayer.jst

I imagine the [Component 11] section should download the realplayer.xpi 
archive, not regus.xpi again.

As already noted, please take Real out of the typical configuration.
(Assignee)

Comment 25

17 years ago
regus.xpi -> realplayer.xpi changed in local tree.
sr=dveditz

Comment 27

17 years ago
one important detail that will require a small change to the packages-mac patch:
The mac automation copies ns/shelf/macppc/realplayer/RealPlayer_for_NS_Installer 
to dist AND RENAMES IT to something more "commercial": RealPlayer Installer

So packages-mac should look like:
[realplayer]
viewer:RealPlayer Installer

My mistake, Samir, since I forgot to inform you about this.
(Assignee)

Comment 28

17 years ago
Created attachment 33988 [details] [diff] [review]
(*) All above fixes incorporated including name change.  (*) Also not doing diskspace check.
samir - where are we on this? 
(Assignee)

Comment 30

17 years ago
Vishy,
Fix ready.  Need to checkin when the tree is open next.
(Assignee)

Comment 31

17 years ago
Fix checked  in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 32

17 years ago
I don't see it getting installed on today's trunk on mac 0522(custom install, 
the installer however, says it's installing the realplayer). After launching the 
browser, I cannot find the plugin inside "components' folder or doing 
'about:plugins" does not list it.
Gbush can you please verify ? Is this a different bug?
(Assignee)

Comment 33

17 years ago
Does real content run though?

Comment 34

17 years ago
Shrirang, do you see a "RealPlayer installer" in the Netscape 6 folder after 
install ?
. If yes, then the problem is in triggering this installer after ours.
. If not, then we need to see if there is anything wrong with the realplayer.xpi 
found in the 'xpi'ftp sub-directory of the installer itself.

Anyone else sees this ?

Comment 35

17 years ago
Samir: realplayer plugin is not found and visiting any page that requires 
realplayer brings upa 'downlaod realplayer dialog'  

JJ : No, i do not see any realplayer installer inside the ns6 folder after 
installation. Btw, i am using the fullinstaller with custom install (realplayer 
selected by default)
(Assignee)

Comment 36

17 years ago
The script expects the installer file in the root of the xpi, now
viewer:RealPlayer Installer.  Patch to script coming up...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 37

17 years ago
Created attachment 35850 [details] [diff] [review]
Tested patch to actually launch the realplayer installer from the right location.
(Assignee)

Comment 38

17 years ago
ssu, please r (patch id 35850).
syd, please sr.

Thanks!
Status: REOPENED → ASSIGNED

Comment 39

17 years ago
r=syd

Please get a mozilla reviewer to sr=;  I am not worthy.

Comment 40

17 years ago
get a r= from sean, sr=syd
Group: netscapeconfidential?

Comment 41

17 years ago
r=ssu

Updated

17 years ago
Group: netscapeconfidential?

Comment 42

17 years ago
a=phil for commercial tree patch
(Assignee)

Comment 43

17 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 44

17 years ago
Verify - RealPlayer on desktop (full and custom builds)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.