Undoing a closed tab does not increment the count of open tabs in the actionbar

VERIFIED FIXED in Firefox 9

Status

defect
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: mfinkle, Assigned: lucasr)

Tracking

Trunk
Firefox 9
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Using the new Tablet UI, in the actionbar we put a count of open tabs in the "show tab" button. The number is inc / dec if you open / close tabs. But it is not inc if you undo a closed tab.

Maybe we need a more fool-proof way of tracking? Can we listen for TabOpen / TabClose events?
Having a look at this one.
Assignee: nobody → lucasr.at.mozilla
Duplicate of this bug: 682405
Blocks: 655762, 679472
OS: Linux → All
Hardware: x86 → All
No longer blocks: 682406
Duplicate of this bug: 682406
Attachment #560308 - Flags: review?(mark.finkle) → review+
Will push to inbound once try goes green:
https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=179780dcf805
Status: NEW → ASSIGNED
Keywords: checkin-needed
Previous try run failed to actually show any results and build api says that rev is 404 (no idea why), so pushed again:
https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=19373e00fd85
Ok, so that try push failed to insert into the schedulerdb as well, so I've just pushed this to inbound to save spending any longer on this.

https://hg.mozilla.org/integration/mozilla-inbound/rev/5f5dc93ba0a8
Target Milestone: --- → Firefox 9
https://hg.mozilla.org/mozilla-central/rev/5f5dc93ba0a8
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110926
Firefox/9.0a1 Fennec/9.0a1
Device: Acer ICONIA A500
OS: Android 3.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.