Closed Bug 682303 Opened 8 years ago Closed 8 years ago

Today build is broken: jemalloc is missing (20110826)

Categories

(Thunderbird :: General, defect, blocker)

x86
Windows 7
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 9.0

People

(Reporter: Aureliano, Assigned: standard8)

References

Details

Attachments

(1 file)

Updating to today build broke TB with warning because "jemalloc is missing"

Reinstalling yesterday build (Mozilla/5.0 (Windows NT 6.1; rv:9.0a1) Gecko/20110825 Thunderbird/9.0a1) all is fine
Yep, we're removing jemalloc.dll on update when we shouldn't be, investigating as to why.
Assignee: nobody → mbanner
Attached patch The fixSplinter Review
Ok, we were removing jemalloc on update when we were not meant to.

This patch makes it so that we only remove jemalloc lib when:

- On linux, all the time, as we used to have a libjemalloc.so but we don't now.
- On Windows only when MOZ_MEMORY isn't defined.
- On Mac only when MOZ_MEMORY_DARWIN isn't defined (the specific definition for Mac).

As our builds define MOZ_MEMORY when appropriate, this should now work correctly.
Attachment #556052 - Flags: review?(dbienvenu)
Comment on attachment 556052 [details] [diff] [review]
The fix

haven't tried it, but this looks like it does what is claimed.
Attachment #556052 - Flags: review?(dbienvenu) → review+
Checked in: http://hg.mozilla.org/comm-central/rev/f66af1873d26

I'll spin up a new nightly as well.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Blocks: 682537
Doesn't seem to be fixed for me, got this error with todays Shredder (6c8a909977d3). I got the full update as I didn't update yesterday, so that might be a factor.
Yeah, that doesn't seem fixed, I'm investigating at the moment.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I landed another follow-up which should fix this:

http://hg.mozilla.org/comm-central/rev/27529ca52af4

I'm watching the builds more closely this time, and there's already another windows nightly running.
The nightly finished rebuilding, and I've confirmed update works fine now.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 9.0
You need to log in before you can comment on or make changes to this bug.