Last Comment Bug 685666 - test/mozmill/Makefile.in relies on target-specific variables being propagated to dependencies
: test/mozmill/Makefile.in relies on target-specific variables being propagated...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla10
Assigned To: Kyle Huey [:khuey] (khuey@mozilla.com)
:
Mentors:
Depends on:
Blocks: 593585
  Show dependency treegraph
 
Reported: 2011-09-08 13:24 PDT by Kyle Huey [:khuey] (khuey@mozilla.com)
Modified: 2011-09-29 09:11 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (684 bytes, patch)
2011-09-08 13:24 PDT, Kyle Huey [:khuey] (khuey@mozilla.com)
ted: review+
k0scist: feedback+
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (khuey@mozilla.com) 2011-09-08 13:24:15 PDT
Created attachment 559259 [details] [diff] [review]
Patch

Which pymake doesn't do (because it's racy and otherwise nasty).  Luckily, afaict there's no reason for this code to use them.

Tagging jhammel for f? just to make sure there was no intent behind this originally.
Comment 1 Jeff Hammel 2011-09-08 15:37:32 PDT
Comment on attachment 559259 [details] [diff] [review]
Patch

I'm not really sure enough about make to sensibly give feedback, but I can tell you what I was trying to do.  Essentially, if PKG_STAGE is defined then it should be overridden for stage-package.  I'm not sure if this does this.

OTOH, mozmill is ticketed to be removed from m-c in its current incarnation anyway: https://bugzilla.mozilla.org/show_bug.cgi?id=676078 . So you could just wipe the stage-package rule entirely and that would be fine.
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-09-29 09:11:54 PDT
https://hg.mozilla.org/mozilla-central/rev/d0a370cc7c85

Note You need to log in before you can comment on or make changes to this bug.