[Tracking] Dealing with suspend issues

RESOLVED DUPLICATE of bug 801199

Status

()

RESOLVED DUPLICATE of bug 801199
7 years ago
4 years ago

People

(Reporter: bbondy, Assigned: bbondy)

Tracking

({meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [metro-mvp][LOE:2])

(Assignee)

Description

7 years ago
I read that Windows 8 will suspend applications around 5 seconds after they switch to a different metro application.

This means it's possible that sometimes we will never be unsuspended.  
This may mean we have to do things like session restore saving a bit differently.

Also some pages may expect to be able to be run even if they are not on screen as it is in a desktop interface.

I'd like to (or have someone else) investigate if we can unsuspended ourselves from a service running in the background.
(Assignee)

Updated

7 years ago
Depends on: 686835

Updated

7 years ago
OS: Windows 8 → Windows 8 Metro
Summary: Dealing with suspend issues and possibly unsuspending ourselves on Metro app swtich → Dealing with suspend issues and possibly unsuspending ourselves on Metro app switch
(Assignee)

Updated

7 years ago
Summary: Dealing with suspend issues and possibly unsuspending ourselves on Metro app switch → Dealing with suspend issues
(Assignee)

Updated

6 years ago
Depends on: 769400
(Assignee)

Updated

6 years ago
Depends on: 769401
(Assignee)

Updated

6 years ago
Assignee: nobody → netzen
(Assignee)

Updated

6 years ago
Blocks: 686835
No longer depends on: 686835
(Assignee)

Updated

6 years ago
Depends on: 753826

Updated

6 years ago
Summary: Dealing with suspend issues → [Tracking] Dealing with suspend issues
(Assignee)

Updated

6 years ago
Assignee: netzen → nobody

Updated

6 years ago
Whiteboard: metro-beta

Updated

6 years ago
Whiteboard: metro-beta → [metro-mvp]

Updated

6 years ago
Whiteboard: [metro-mvp] → [metro-mvp][LOE:2]
(Assignee)

Updated

6 years ago
Assignee: nobody → netzen
Whiteboard: [metro-mvp][LOE:2] → [metro-mvp][LOE:2][metro-it2]
(Assignee)

Comment 1

6 years ago
Since this is a tracking bug, removing metro-it2
Whiteboard: [metro-mvp][LOE:2][metro-it2] → [metro-mvp][LOE:2]

Updated

6 years ago
Keywords: meta

Updated

6 years ago
Blocks: 801199
No longer depends on: 801199
(Assignee)

Updated

6 years ago
No longer depends on: 769401
(Assignee)

Updated

6 years ago
No longer depends on: 753826
(Assignee)

Updated

6 years ago
No longer depends on: 769400
(Assignee)

Updated

6 years ago
No longer depends on: 795887
(Assignee)

Updated

6 years ago
No longer blocks: 686835, 801199
(Assignee)

Comment 2

6 years ago
Just using appropriate story to track this instead of it having its separate tracking bug: Bug 801199 - Story – Session restore
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 801199
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.