Last Comment Bug 687766 - Remove binary xpidl from the tree
: Remove binary xpidl from the tree
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Matheus Kerschbaum
:
: Gregory Szorc [:gps]
Mentors:
: 686692 (view as bug list)
Depends on: 578790 689555
Blocks: 709793
  Show dependency treegraph
 
Reported: 2011-09-19 21:31 PDT by Matheus Kerschbaum
Modified: 2011-12-12 08:09 PST (History)
3 users (show)
matjk7: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
part 1: Remove build-time dependency on glib and libIDL (31.14 KB, patch)
2011-09-19 21:37 PDT, Matheus Kerschbaum
no flags Details | Diff | Splinter Review
part 2: Nuke binary xpidl (212.64 KB, patch)
2011-09-19 21:38 PDT, Matheus Kerschbaum
no flags Details | Diff | Splinter Review
part 1: Remove build-time dependency on libIDL (21.66 KB, patch)
2011-09-25 08:00 PDT, Matheus Kerschbaum
khuey: review+
Details | Diff | Splinter Review
part 2: Nuke binary xpidl (212.64 KB, patch)
2011-09-25 08:02 PDT, Matheus Kerschbaum
khuey: review+
Details | Diff | Splinter Review
part 1: Remove build-time dependency on libIDL (22.18 KB, patch)
2011-09-26 14:07 PDT, Matheus Kerschbaum
matjk7: review+
Details | Diff | Splinter Review

Description Matheus Kerschbaum 2011-09-19 21:31:40 PDT

    
Comment 1 Matheus Kerschbaum 2011-09-19 21:37:29 PDT
Created attachment 561117 [details] [diff] [review]
part 1: Remove build-time dependency on glib and libIDL
Comment 2 Matheus Kerschbaum 2011-09-19 21:38:05 PDT
Created attachment 561118 [details] [diff] [review]
part 2: Nuke binary xpidl
Comment 3 Matheus Kerschbaum 2011-09-25 08:00:34 PDT
Created attachment 562301 [details] [diff] [review]
part 1: Remove build-time dependency on libIDL

First patch was overly ambitious and broke elf-dynstr-gc which uses the glib stuff from configure.
Comment 4 Matheus Kerschbaum 2011-09-25 08:02:05 PDT
Created attachment 562302 [details] [diff] [review]
part 2: Nuke binary xpidl

Now with a nicer commit message.
Comment 5 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-09-26 05:32:13 PDT
Comment on attachment 562301 [details] [diff] [review]
part 1: Remove build-time dependency on libIDL

Review of attachment 562301 [details] [diff] [review]:
-----------------------------------------------------------------

Have you verified that this works on Windows?  That's the only part of this that worries me.

::: config/system-headers
@@ -404,5 @@
>  libgnomevfs/gnome-vfs-mime-handlers.h
>  libgnomevfs/gnome-vfs-mime-utils.h
>  libgnomevfs/gnome-vfs-ops.h
>  libgnomevfs/gnome-vfs-standard-callbacks.h
> -libIDL/IDL.h

Should we be removing IDL.h (line 311) too?
Comment 6 Matheus Kerschbaum 2011-09-26 14:06:57 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #5)
> Have you verified that this works on Windows?  That's the only part of this
> that worries me.

https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=0aba62ed8509

> Should we be removing IDL.h (line 311) too?

Yes!
Comment 7 Matheus Kerschbaum 2011-09-26 14:07:51 PDT
Created attachment 562531 [details] [diff] [review]
part 1: Remove build-time dependency on libIDL
Comment 9 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-09-27 05:37:34 PDT
https://hg.mozilla.org/mozilla-central/rev/587115c590ff
https://hg.mozilla.org/mozilla-central/rev/d1fb12e77362
Comment 10 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-10-10 12:22:25 PDT
*** Bug 686692 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.