Pasting fails in scratchpad after editing large buffers

RESOLVED DUPLICATE of bug 684862

Status

()

Firefox
Developer Tools
RESOLVED DUPLICATE of bug 684862
6 years ago
6 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sourceeditor][orion])

(Reporter)

Description

6 years ago
STR:

1. Go to <http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js?raw=1>, select all, copy.
2. Open Scratchpad, select all, paste.
3. Add some newlines somewhere in the buffer, and then backspace to remove them.  What I do to reproduce this reliably is I go to line 8684 (this line: |onEnabled: function(aAddon) this.onInstalled(),|), press the caret before the "f" in function, press enter 4 times, and then backspace enough times to effective undo the line insertions.
4. Go to <https://bugzilla.mozilla.org/js/yui/yahoo-dom-event/yahoo-dom-event.js?1303753510>, select all, copy.
5. Go to scratchpad, select all, paste.  Nothing happens.

Comment 1

6 years ago
I have posted a comment upstream to see if this is the same bug as: https://bugs.eclipse.org/bugs/show_bug.cgi?id=355230

Updated

6 years ago
Whiteboard: [sourceeditor][orion]
Somehow I missed this bug when testing for bug 692807.

Tested now. The bug is fixed and it's the manifestation of bug 684862.

Please reopen if you believe this is not fixed. Thank you!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 684862
You need to log in before you can comment on or make changes to this bug.