Last Comment Bug 692807 - Update the code from Orion upstream
: Update the code from Orion upstream
Status: RESOLVED FIXED
[sourceeditor][orion][fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 10
Assigned To: Mihai Sucan [:msucan]
:
:
Mentors:
Depends on:
Blocks: 678995 680375 680509 684862 687565 687855
  Show dependency treegraph
 
Reported: 2011-10-07 09:09 PDT by Mihai Sucan [:msucan]
Modified: 2011-11-01 09:55 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
proposed patch (215.43 KB, patch)
2011-10-11 07:39 PDT, Mihai Sucan [:msucan]
rcampbell: review+
Details | Diff | Splinter Review
updated patch - test fixes (216.10 KB, patch)
2011-10-12 06:03 PDT, Mihai Sucan [:msucan]
no flags Details | Diff | Splinter Review

Description Mihai Sucan [:msucan] 2011-10-07 09:09:00 PDT
We need to update Orion to use the newer code from Eclipse.
Comment 1 Mihai Sucan [:msucan] 2011-10-11 07:39:52 PDT
Created attachment 566218 [details] [diff] [review]
proposed patch

This is the proposed patch.

Changes:

- fixed bug 678995 and bug 680375 by adding padding to the line gutter.
- fixed bug 680509 - now Orion highlights the current line by default.
- partial fix for bug 680465: Orion now recognizes /* comments */ in CSS. Some properties are still unrecognized and // comments are still highlighted, which is wrong and confusing.
- see bug 681360 comment 1.
- fixes for bug 684862, bug 685925, bug 687565, bug 687850, bug 687855 and bug 689559.

This patch doesn't fix: bug 687573, bug 687577, bug 687580, bug 687861.

Before we can enable Orion by default I would suggest we fix: bug 687573, bug 687577 and 687580.

Thoughts?

Looking forward for your review!
Comment 2 Rob Campbell [:rc] (:robcee) 2011-10-11 15:39:31 PDT
Comment on attachment 566218 [details] [diff] [review]
proposed patch

oh noe! tabs!

r+ with a successful run through try.
Comment 3 Mihai Sucan [:msucan] 2011-10-12 06:03:25 PDT
Created attachment 566503 [details] [diff] [review]
updated patch - test fixes

Rob, thank you for the r+!

Updated the patch to include more test fixes, this time for the textarea fallback. The cut/copy/paste event handling became async in Orion. In the previous patch I did address those changes, but it looks like I broke the testing for the textarea fallback. Fixed this now, in this patch.

Patch also pushed to try:
https://tbpl.mozilla.org/?tree=Try&rev=600398ece62a
Comment 4 Rob Campbell [:rc] (:robcee) 2011-10-12 12:01:10 PDT
looks good! Thanks!
Comment 5 Rob Campbell [:rc] (:robcee) 2011-10-13 06:38:22 PDT
https://hg.mozilla.org/integration/fx-team/rev/a67b2587a4cc
Comment 6 Rob Campbell [:rc] (:robcee) 2011-10-13 10:02:18 PDT
https://hg.mozilla.org/mozilla-central/rev/a67b2587a4cc
Comment 7 Dão Gottwald [:dao] 2011-11-01 09:18:00 PDT
Comment on attachment 566503 [details] [diff] [review]
updated patch - test fixes

>--- /dev/null
>+++ b/browser/devtools/sourceeditor/orion/mozilla.css
>@@ -0,0 +1,11 @@
>+/* Any copyright is dedicated to the Public Domain.
>+   http://creativecommons.org/publicdomain/zero/1.0/ */

Mozilla code is supposed to use the MPL.
Comment 8 Mihai Sucan [:msucan] 2011-11-01 09:55:38 PDT
(In reply to Dão Gottwald [:dao] from comment #7)
> Comment on attachment 566503 [details] [diff] [review] [diff] [details] [review]
> updated patch - test fixes
> 
> >--- /dev/null
> >+++ b/browser/devtools/sourceeditor/orion/mozilla.css
> >@@ -0,0 +1,11 @@
> >+/* Any copyright is dedicated to the Public Domain.
> >+   http://creativecommons.org/publicdomain/zero/1.0/ */
> 
> Mozilla code is supposed to use the MPL.

True. I thought the code is minimal enough to not need the whole MPL boilerplate. Much bigger than the CSS itself.

Shall I make a patch to switch to MPL?

(thanks for checking out the patch!)

Note You need to log in before you can comment on or make changes to this bug.