Last Comment Bug 688860 - Cannot switch spell check language with multiple compose windows open
: Cannot switch spell check language with multiple compose windows open
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Message Compose Window (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 11.0
Assigned To: Jesper Kristensen
:
Mentors:
: 700631 716506 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-23 13:37 PDT by Jesper Kristensen
Modified: 2013-08-26 11:52 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (4.71 KB, patch)
2011-09-23 13:37 PDT, Jesper Kristensen
standard8: review+
Details | Diff | Splinter Review
Suite bustage fix. (1.66 KB, patch)
2011-11-29 21:12 PST, Philip Chee
neil: review+
Details | Diff | Splinter Review

Description Jesper Kristensen 2011-09-23 13:37:13 PDT
Created attachment 562153 [details] [diff] [review]
patch

In investigating bug 687319 I found this.

Steps to reproduce:
1. Have two dictionaries installed, for example the built in en-US plus https://addons.mozilla.org/da/firefox/addon/dansk-ordbog/
2. Have two compose windows open
3. Switch focus between the main editing area of the two windows a couple of times
4. Try to switch between dictionaries a couple of times

Expected result: Selected language changes
Actual result: Selected language gets stuck

Possibly related to bug 338427 and/or bug 591780.
Comment 1 Philip Chee 2011-09-23 22:34:13 PDT
Normally you need a suite peer for the suite part of that patch, but I guess Standard8's r+ would be good enough for us here.
Comment 2 Mark Banner (:standard8) 2011-11-24 04:22:45 PST
Comment on attachment 562153 [details] [diff] [review]
patch

Sorry for the delay in getting to this. It looks fine.

Thanks for the patch.
Comment 3 Mark Banner (:standard8) 2011-11-29 12:21:50 PST
Checked in: http://hg.mozilla.org/comm-central/rev/aa5b97afb1f2
Comment 4 Philip Chee 2011-11-29 21:12:43 PST
Created attachment 577855 [details] [diff] [review]
Suite bustage fix.

Error: gSpellChecker is not defined
Source file: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 2219
 ----------
Error: gSpellChecker is not defined
Source file: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 2207

Suite should switch to InlineSpellChecker.jsm eventually. Meanwhile this is a minimal bustage fix. I'll take a review from any suite/mailnews peer whoever gets to it first.
Comment 5 neil@parkwaycc.co.uk 2011-11-30 00:33:54 PST
Comment on attachment 577855 [details] [diff] [review]
Suite bustage fix.

In the Compose window the variable might have been called sSpellChecker ;-) (although it might in future be possible to declare the spell checker in an editor overlay in which case it would be gSpellChecker again...)
Comment 6 Philip Chee 2011-11-30 04:34:15 PST
Comment on attachment 577855 [details] [diff] [review]
Suite bustage fix.

Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/58cf9351cc23

Apologies to Jesper Kristensen for not spotting this earlier.
Comment 7 u331436 2011-12-06 11:18:46 PST
*** Bug 700631 has been marked as a duplicate of this bug. ***
Comment 8 [:Aleksej] 2013-08-26 11:52:19 PDT
*** Bug 716506 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.