'h' entered as first letter in location bar is overwritten with 'w' when browser.urlbar.autoFill is true

RESOLVED DUPLICATE of bug 678352

Status

()

Firefox
Location Bar
RESOLVED DUPLICATE of bug 678352
6 years ago
6 years ago

People

(Reporter: raamee, Unassigned)

Tracking

7 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 563315 [details]
Firefox-h-probelm.gif

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110922153450

Steps to reproduce:

Uninstalled firefox 6.0.2 and Installed firefox 7.


Actual results:

When I start type 'h' in the address bar , the address bar replaces it as 'w'. I think due to the removal of http in the address bar , this problem occurs. 


Expected results:

It should not replace 'h' to 'w'.

Comment 1

6 years ago
I can confirm this. For me it takes to type 'ht' because there are sites that begin the server name with 'h'.
But it may be intentional, as you say, due to the intentional hiding of http://. But it may be confusing to the users.
Status: UNCONFIRMED → NEW
Component: General → Location Bar
Ever confirmed: true
OS: Windows 7 → All
QA Contact: general → location.bar
Hardware: x86 → All

Comment 2

6 years ago
I cannot reproduce this with clean profile. can you try this on new profile? http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows

Comment 3

6 years ago
Ek, you need to have some URL history so that the awesomebar can mach something.

Comment 4

6 years ago
I've tested on dirty profile, yeah, a lot of history but I have no luck. Still cannot reproduce this. perhaps, it's an add-on related. http://i.imgur.com/eicgY.png

Comment 5

6 years ago
Can you try creating the history in Firefox 6 and then upgrade to 7? I notice in FF7 the matched history entries (in the drop down suggestion list) do not show the http:// protocol. In FF10 the entries show with the protocol. Is it stored differently, or just displayed differently?

Comment 6

6 years ago
have you set browser.urlbar.autoFill to true? If so perhaps you ought to set it back to false.

Comment 7

6 years ago
It does happen for me on FF7 even in Safe mode, with a profile migrated from old Firefoxes (all the way from about 1.0 :)).
Typing http ends up as wwtp and that does not match anything (similar to what is seen on the attached video).

I have the pref browser.urlbar.matchOnlyTyped set to true.
Also browser.urlbar.autoFill is true.

Setting browser.urlbar.trimURLs to false (non-default) OR browser.urlbar.autoFill to false (default) makes the bug disappear.

Comment 8

6 years ago
(In reply to aceman from comment #5)
> Can you try creating the history in Firefox 6 and then upgrade to 7? I
> notice in FF7 the matched history entries (in the drop down suggestion list)
> do not show the http:// protocol. In FF10 the entries show with the
> protocol. Is it stored differently, or just displayed differently?

Firefox 7,8,9,10 will not show http:// protocol in drop down suggestion, but https:// protocol.

I retested this by remove all profile, installed firefox 6.0.2 and browse a lot of web and uninstalled firefox 6. installed firefox 7. I still don't get any problem.

Comment 9

6 years ago
Then try to toggle the prefs I have mentioned in about:config.

Comment 10

6 years ago
no problem at all even if browser.urlbar.autoFill set to true.
bug 559878 is for browser.urlbar.autoFill

Comment 12

6 years ago
Well, the original reporter here also has autoFill on, it is seen on the video. However, in bug 559878 comment 33 wants to take the approach from comment 30. But this bug matches comment 33 and comment 28. Also notice the bug 559878 comment 0 specifically says the problem happens when the text matches an open tab. I have commented here that the problem for me does NOT happen when it does not match URL of an open tab.
Now when I look at it, my comment is missing here. Didn't someone mid-air collide it?:)

I am for merging these bugs, but make sure bug 559878 fully covers this one.

Comment 13

6 years ago
This can easily be reproduced with a clean installation without existing user profile on OSX and Linux.  Install 7.0, run, go to about:config, set browser.urlbar.autofill to true, close any other open tabs, type https in urlbar.  It will autofill to www.mozilla.org/en-US/firefox/help.  The previous behavior would have been to autocomplete the http portion but now that it is hidden it replaces the first char with w and doesn't revert to the char previously typed when it no longer matches an existing history item. You get the exact same behavior on an upgrade when trying to type https://, if you have www.hulu.com in or some other domain beginning with an h but permanently redirects to www.h... in your history. This prevents a user from typing https without having to keep typing until nothing matches and then going back to edit the w out.  This is obviously due to the 7.0 change in Bug 665580 which was justified as Chrome parity.  Chrome also has autofill so please don't suggest I just turn it off.

Updated

6 years ago
Blocks: 665580
Summary: Firefox 'h' issue in address bar → 'h' entered as first letter in location bar is overwritten with 'w' when browser.urlbar.autoFill is true

Comment 14

6 years ago
It seems like this is a duplicate of Bug 678352.

Comment 15

6 years ago
Yes, thanks.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 678352

Updated

6 years ago
No longer blocks: 665580
You need to log in before you can comment on or make changes to this bug.