Last Comment Bug 678352 - 'h' entered as first letter in location bar is overwritten with 'w' when browser.urlbar.autoFill is true
: 'h' entered as first letter in location bar is overwritten with 'w' when brow...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Location Bar (show other bugs)
: 7 Branch
: x86 Linux
: -- normal with 6 votes (vote)
: Firefox 12
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 685121 685643 689986 690244 692008 696420 696649 699198 701636 705383 726350 728734 735972 737131 (view as bug list)
Depends on: 566489
Blocks: 665580
  Show dependency treegraph
 
Reported: 2011-08-11 14:19 PDT by Wil Clouser [:clouserw]
Modified: 2014-05-23 02:22 PDT (History)
28 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshots (282.29 KB, image/png)
2011-08-11 14:19 PDT, Wil Clouser [:clouserw]
no flags Details
can't reproduce (954.12 KB, video/webm)
2011-09-29 02:53 PDT, Ekanan Ketunuti
no flags Details
The location bar after typing "h" (3.31 KB, image/png)
2011-10-06 07:28 PDT, Jerry Baker
no flags Details

Description Wil Clouser [:clouserw] 2011-08-11 14:19:19 PDT
Created attachment 552497 [details]
screenshots

Mozilla/5.0 (X11; Linux i686; rv:8.0a1) Gecko/20110809 Firefox/8.0a1


My goal:

Type "https://www.paypal.com" into my awesomebar.  (Specifically, I want to specify the "https" part of a URL)

Expected results:  

I can do that.

Actual results:

Can't get to SSL sites. :(  I type "ht" and it matches on a url with "ht" in it elsewhere which starts with "ww".  When I type the third 't' the last of the "www" url is highlighted so my "htt" has turned in to "wwt" in the URL bar and it starts matching on that now.

This is totally hard to explain without a screencast and I don't have one of those, but I do have some sweet screenshots which I'm attaching.

I'm not pausing or anything when typing these letters, just a smooth h-t-t-p-s turns into w-w-t-p-s.
Comment 1 Wil Clouser [:clouserw] 2011-08-11 14:33:22 PDT
Thanks to James' pref skills we've determined this is because I had browser.urlbar.autoFill = True which is not the default.

So, leaving the bug open, but it's solved for me by disabling that.  Not sure how it got enabled. :-/
Comment 2 James Socol [:jsocol, :james] 2011-08-11 14:36:10 PDT
On Windows 7 in Nightly (2011-08-11) I can turn on browser.urlbar.autoFill and type straight through the autocomplete without running into this.
Comment 3 key88sf 2011-09-29 02:14:57 PDT
*** Bug 689986 has been marked as a duplicate of this bug. ***
Comment 4 Ekanan Ketunuti 2011-09-29 02:53:32 PDT
Created attachment 563355 [details]
can't reproduce

I spend much time on this bug and bug 690244 but can't reproduce the problem.

Mozilla/5.0 (Windows NT 6.1; rv:10.0a1) Gecko/20110928 Firefox/10.0a1
Built from http://hg.mozilla.org/mozilla-central/rev/7f4867717226
Comment 5 James Socol [:jsocol, :james] 2011-09-29 07:14:13 PDT
I was wrong in comment 2--or, I was right at the time. This appears to depend somewhat on what's in your places database.

Trying to type "how do": http://screencast.com/t/bJu3y7LZ
Trying to type "https://": http://screencast.com/t/MuZuY9XXxj
Comment 6 Marco Bonardo [::mak] 2011-10-04 06:58:21 PDT
*** Bug 685121 has been marked as a duplicate of this bug. ***
Comment 7 Jerry Baker 2011-10-06 07:24:58 PDT
Firefox autoupdated to 7.0 and now I can no longer access my router because of this bug (unless I want to give up autocomplete altogether). The router only accepts https connections, but if I try to type "https" in the location bar, it gets overwritten as described by others. If I just type in the IP address of my router FF attempts a plain http connection.
Comment 8 Jerry Baker 2011-10-06 07:28:44 PDT
Created attachment 565215 [details]
The location bar after typing "h"

Screenshot attached from Windows XP. Changing platform to ALL.
Comment 9 James Socol [:jsocol, :james] 2011-10-06 07:29:09 PDT
Jerry, as a work around, let it change the 'h' to a 'w', then once you've got a few more characters, you can go back and change the 'w' back to an 'h' manually.
Comment 10 :aceman 2011-10-06 08:33:50 PDT
*** Bug 690244 has been marked as a duplicate of this bug. ***
Comment 11 Jerry Baker 2011-10-06 09:01:49 PDT
(In reply to James Socol [:jsocol, :james] from comment #9)
> Jerry, as a work around, let it change the 'h' to a 'w', then once you've
> got a few more characters, you can go back and change the 'w' back to an 'h'
> manually.

Thank you. A better workaround allows you to turn off the silly feature of hiding the protocol (e.g., http, ftp, https, etc.). Use about:config to change browser.urlbar.trimURLs to false.
Comment 12 Steffen Wilberg 2011-10-06 09:05:31 PDT
Or set browser.urlbar.autoFill to false.
Comment 13 Jerry Baker 2011-10-06 09:12:41 PDT
(In reply to Steffen Wilberg from comment #12)
> Or set browser.urlbar.autoFill to false.

That does work, but then autofill will still be broken - just in a different way. Why would you trade one bustage for another when you can disable protocol hiding and lose nothing?
Comment 14 mozilla.1.funnel 2011-10-14 07:25:06 PDT
I have the same issue. Thank you for posting a bug about this already. This issue occurs when I attempt to reach websites that begin with an "h," for example, hypem.com

To clarify, I have hulu as a search keyword saved in my favorites. 
Address: http://www.hulu.com/search?query=%s
Keyword: h
(this may be the issue, but even if it is, firefox should recognize that I am *not* searching hulu when I attempt to type in an address that starts with the same letter

How to replicate:
When I type "h" (without any following space) into the address bar, autocomplete fills in "www.hulu.com/search?query=" with the entire search term highlighted, except for the first "w." When I continue typing an address, for example, hypem.com, the address bar reads "wypem.com"

Firefox should understand that keyword searches should only be done when followed by a space and not autoreplace the url because it starts with the same letter
Comment 15 bugzilla 2011-10-14 09:50:19 PDT
Instead of setting browser.urlbar.autoFill to false, you can also type a Space (press Spacebar) and then the desired text.
Comment 16 raamee 2011-10-14 09:53:20 PDT
(In reply to bugzilla from comment #15)
> Instead of setting browser.urlbar.autoFill to false, you can also type a
> Space (press Spacebar) and then the desired text.

Cool.Nice trick.
Comment 17 mozilla.1.funnel 2011-10-16 12:21:28 PDT
Thanks Bugzilla, that is a good temporary workaround. Would be great if the normal functionality is fixed to avoid having to remember to hit space before all URLs that start with "h" though. By the way, I am running 7.0.1 on Windows 7 x64, unlike the OP
Comment 18 bugzilla 2011-10-16 13:45:26 PDT
Also FF8 (Beta) is affected (Win7 x64). (I'm on the current beta channel)
Comment 19 Marco Bonardo [::mak] 2011-10-21 05:48:28 PDT
I guess bug 566489 may fix this, so adding dependency for now.
Comment 20 Bobby Johnson [:rjohnson19] 2011-10-23 11:22:56 PDT
*** Bug 696649 has been marked as a duplicate of this bug. ***
Comment 21 Thomas Ahlblom 2011-11-02 13:13:42 PDT
*** Bug 699198 has been marked as a duplicate of this bug. ***
Comment 22 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-11-11 11:58:52 PST
*** Bug 701636 has been marked as a duplicate of this bug. ***
Comment 23 Alice0775 White 2011-11-26 03:52:50 PST
*** Bug 705383 has been marked as a duplicate of this bug. ***
Comment 24 Tim (fmdeveloper) 2011-12-23 17:14:24 PST
*** Bug 685643 has been marked as a duplicate of this bug. ***
Comment 25 Tim (fmdeveloper) 2011-12-23 17:16:51 PST
*** Bug 696420 has been marked as a duplicate of this bug. ***
Comment 26 Tim (fmdeveloper) 2011-12-23 17:25:33 PST
*** Bug 692008 has been marked as a duplicate of this bug. ***
Comment 27 Tim (fmdeveloper) 2011-12-23 17:27:39 PST
Is this a duplicate of Bug 559878?
Comment 28 Stilez 2012-01-12 16:55:57 PST
Confirming this bug and yes, it looks the same behavior as 559878.

See request for help here:
https://support.mozilla.org/en-US/questions/911930
with the following description, which might help in replicating the bug:


URL inline autocomplete fails on "https:" protocol

As I type the letters h-t-t-p-s into the URL bar (a URL that only has HTTPS access), it tries to automatch them with websites I've visited. For example as I type the letter "h" it suggests matches such as "c_h_rome" or pages ending "_h_tm". As I type a second character ("ht") it narrows its suggestions and suggests pages ending "_ht_ml"...

As I type a 3rd character ("htt" -) it suddenly suggests a full URL in-line ** and overwrites what I've typed to do so **, so I can't actually type the letters "https".
Comment 29 Matt Brubeck (:mbrubeck) 2012-01-20 10:03:40 PST
This seems to be fixed by the landing of bug 566489.
Comment 30 Ibraim 2012-02-06 09:17:12 PST
(In reply to Matt Brubeck (:mbrubeck) from comment #29)
> This seems to be fixed by the landing of bug 566489.

This is fixed in which version? I use version 10.0 and I still have the problem.
Comment 31 Matt Brubeck (:mbrubeck) 2012-02-06 10:53:23 PST
(In reply to Ibraim from comment #30)
> This is fixed in which version? I use version 10.0 and I still have the
> problem.

Fixed in version 12.
Comment 32 Marco Bonardo [::mak] 2012-02-06 11:01:53 PST
well, due to the backout in bug 720792 this is technically untrue, will be really fixed when bug 720792 will be.
Comment 33 Matthias Versen [:Matti] 2012-02-12 05:42:24 PST
*** Bug 726350 has been marked as a duplicate of this bug. ***
Comment 34 Matthias Versen [:Matti] 2012-02-19 14:24:41 PST
*** Bug 728734 has been marked as a duplicate of this bug. ***
Comment 35 Matthias Versen [:Matti] 2012-03-14 20:53:14 PDT
*** Bug 735972 has been marked as a duplicate of this bug. ***
Comment 36 David McDivitt 2012-03-15 07:12:59 PDT
*** Bug 735972 has been marked as a duplicate of this bug. ***
Comment 37 Marco Bonardo [::mak] 2014-05-23 02:22:25 PDT
*** Bug 737131 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.