Last Comment Bug 691012 - DOMTemplate needs chrome tests
: DOMTemplate needs chrome tests
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 10
Assigned To: Joe Walker [:jwalker] (needinfo me or ping on irc)
:
Mentors:
Depends on: 684958 692424
Blocks: 692031 704918
  Show dependency treegraph
 
Reported: 2011-10-01 01:11 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2012-01-05 08:33 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
upload 1 (6.97 KB, patch)
2011-10-07 12:55 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
no flags Details | Diff | Review
upload 2 (7.28 KB, patch)
2011-10-11 08:50 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
rcampbell: review+
Details | Diff | Review
upload 3 (7.25 KB, patch)
2011-10-12 07:31 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
no flags Details | Diff | Review

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-10-01 01:11:41 PDT
These tests should be ported:
https://github.com/joewalker/domtemplate/blob/master/test/index.html
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-10-07 12:55:36 PDT
Created attachment 565618 [details] [diff] [review]
upload 1

Rob back in bug 684958 comment 11, you asked for templater tests. Theses are they. One of the tests is commented out because it uncovered bug 692031. I'll be uploading a patch there to soon.
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-10-07 12:57:33 PDT
Pls ignore typos in comments. It's late. :)
Comment 3 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-10-11 08:50:14 PDT
Created attachment 566239 [details] [diff] [review]
upload 2

Minor tweaks as a result of the changes in bug 692424.

We're deleting an HTML file that was added in bug 692424 - it's just an easy way of getting out of make wanting HTML files to copy. Call me lazy, I'm sure there is a better way, but this has the same effect and it works :)
Comment 4 Rob Campbell [:rc] (:robcee) 2011-10-11 15:49:47 PDT
Comment on attachment 566239 [details] [diff] [review]
upload 2

diff --git a/browser/devtools/shared/test/browser_templater_basic.html b/browser/devtools/shared/test/browser_templater_basic.html
new file mode 100644

+</html>
\ No newline at end of file

good! thanks for the tests! :)
Comment 5 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-10-12 07:31:26 PDT
Created attachment 566526 [details] [diff] [review]
upload 3

Adds newline :)
Comment 6 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-10-12 07:52:26 PDT
Try log:
https://tbpl.mozilla.org/?tree=Try&rev=f2eedda104b1
Comment 7 Rob Campbell [:rc] (:robcee) 2011-10-12 10:14:38 PDT
upload 3: https://hg.mozilla.org/integration/fx-team/rev/4322ee96f796
Comment 8 Rob Campbell [:rc] (:robcee) 2011-10-13 09:52:44 PDT
https://hg.mozilla.org/mozilla-central/rev/4322ee96f796

Note You need to log in before you can comment on or make changes to this bug.