If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add-on Promo banners: Tracking

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Discovery Pane
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: Dan Horner, Assigned: Bill)

Tracking

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110916091512

Steps to reproduce:

We would like to have a better idea of metrics around the promo banners, specifically a report covering the following:

Number of impressions per banner
Number of clicks and installs from each banner
- broken down by add-on clicked / installed
- and bounce rate
Number of video plays from banner (educational video)

If possible, we would like this broken down by country and language. Please let me know if this is possible. Thanks.

Comment 1

6 years ago
Hey Brad - Sending this your way - can you help out here?

Dan - Questions for you before Brad can help:

1. It looks like you want to measure 2 conversion events stemming from these banners: a)Installs of Add-ons b) Video plays - have all these custom events been tagged in Webtrends? (details on how to do that here https://wiki.mozilla.org/Engagement/Analytics/Webtrends/Tracking)

2. Will the video be within the banner, or link to a page where the video lives? If linking to another page, what's the URL for that banner?

Once those questions are answered Brad should be able to take it from here.
Assignee: nobody → brad.gross
(Reporter)

Comment 2

6 years ago
Hi Laura

>1. It looks like you want to measure 2 conversion events stemming from these banners: a)Installs of Add-ons b) Video plays - have all these custom events been tagged in Webtrends? (details on how to do that here https://wiki.mozilla.org/Engagement/Analytics/Webtrends/Tracking)

Will defer to Wil -or the add-ons team- for this one (I don't think any tracking has been added though). Wil, let me know if this is straightforward to add, and if I need to create a separate implementation bug.

> 2. Will the video be within the banner, or link to a page where the video lives? If linking to another page, what's the URL for that banner?

Video will be shown in a light box. See bug 680941 for more details. The banner is not live yet - Wil, any way we can provide a URL before we launch?

Thanks
No tracking has been added yet.

Video plays seems relatively straightforward using the wiki page Laura linked to.  Add-on installs would be if they were on the same page.  If the action is to load this page, see an add-on you like and click to its detail page and then click install that is not a flow that is covered by the wiki page.

> Video will be shown in a light box. See bug 680941 for more details. The
> banner is not live yet - Wil, any way we can provide a URL before we launch?

URL for what?
(Reporter)

Comment 4

6 years ago
>> Video will be shown in a light box. See bug 680941 for more details. The
>> banner is not live yet - Wil, any way we can provide a URL before we launch?

>URL for what?

As per Laura's request:

> 2. Will the video be within the banner, or link to a page where the video lives? If > linking to another page, what's the URL for that banner?

We need the banner which enclosed the video from bug 680941
(In reply to Dan Horner from comment #2)
> Will defer to Wil -or the add-ons team- for this one (I don't think any
> tracking has been added though). Wil, let me know if this is straightforward
> to add, and if I need to create a separate implementation bug.

Please file a separate bug with the specifics about anything you need on the AMO site. Thanks
Depends on: 680941

Comment 6

6 years ago
If you have any questions about how to implement the tracking code please feel free to shoot me an email.
(Reporter)

Comment 7

6 years ago
Hi Will - specifics are detailed on the dependent bug - 680941

Is there anything else that you need?
I don't, greg will tell us if he has questions.

Comment 9

6 years ago
Hey guys, not sure why I am CCed on this bug. Is there any action needed from my end?
(Reporter)

Comment 10

6 years ago
Sorry, wrong Greg - meant to add Greg Koberger instead.

Updated

6 years ago
Assignee: brad.gross → bill.baker
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.