Last Comment Bug 692130 - move panorama code to browser/components/tabview
: move panorama code to browser/components/tabview
Status: RESOLVED FIXED
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: All All
: -- normal
: Firefox 10
Assigned To: :Gavin Sharp [email: gavin@gavinsharp.com]
:
:
Mentors:
Depends on: 695320
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-05 09:10 PDT by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2016-04-12 14:00 PDT (History)
3 users (show)
gavin.sharp: in‑testsuite-
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (48.02 KB, patch)
2011-10-05 09:37 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
no flags Details | Diff | Splinter Review
real patch (55.63 KB, patch)
2011-10-05 09:38 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
ttaubert: review+
Details | Diff | Splinter Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2011-10-05 09:10:25 PDT
It's frustrating to need to wait for all the panorama test to run when running tests in browser/base/content that have nothing to do with it. We can pretty easily move the panorama code to browser/components/tabview, I think, which would solve that problem.
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-10-05 09:37:20 PDT
Created attachment 564891 [details] [diff] [review]
patch
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-10-05 09:38:23 PDT
Created attachment 564893 [details] [diff] [review]
real patch
Comment 3 Tim Taubert [:ttaubert] 2011-10-06 05:41:56 PDT
Comment on attachment 564893 [details] [diff] [review]
real patch

Review of attachment 564893 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for doing that!
Comment 4 Tim Taubert [:ttaubert] 2011-10-06 13:23:36 PDT
https://hg.mozilla.org/integration/fx-team/rev/bdd575bda8ab
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-10-06 14:24:54 PDT
I accidentally also pushed this to inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2326508537f8

Let's see what happens!
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-10-06 14:46:33 PDT
I backed this out of fx-team, since it also landed on inbound with some minor changes do to a merge requirement:

https://hg.mozilla.org/integration/fx-team/rev/36e6eb27d0c2

I think HG fubared the backout with removals+additions :(
Comment 7 Ed Morley [:emorley] 2011-10-06 16:14:19 PDT
mbrubeck pushed a followup to inbound to resolve bustage:
https://hg.mozilla.org/integration/mozilla-inbound/rev/94f2fa9f97b8
Comment 8 Ed Morley [:emorley] 2011-10-06 18:44:13 PDT
Even after the followup, this is still believed to be the cause of:
{
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/tabview/test/browser_tabview_bug595518.js | Test timed out
}
(eg https://tbpl.mozilla.org/php/getParsedLog.php?id=6713613&tree=Mozilla-Inbound)

However due to 12 pushes in a row being either red or containing permaoranges, it's not entirely clear what the cause was.

Discussions on #developers between myself, mbrubeck, callek & others, came to the conclusion that we either needed to clean slate hg revert -r last known inbound green (which would have backed this out anyway), or have one last attempt by backing out this bug using hg backout in the hope hg backout wouldn't mess up the renames. The latter was performed using mercurial 1.9.2, but mercurial has unfortunately still not coped with them. The only consolation being that a complete revert to 12+ pushes prior to tip, would have lost the renames regardless.

Backout:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a589eefb2dad
https://hg.mozilla.org/integration/mozilla-inbound/rev/ed12a4461eeb
https://hg.mozilla.org/integration/mozilla-inbound/rev/2db24d928e6c
https://hg.mozilla.org/integration/mozilla-inbound/rev/a589eefb2dad

When this relands, feel free to exclude the tweak you made to bug 689884 if that makes things simpler, since if left it will done by bug 692625 anyway.
Comment 9 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-10-20 10:59:26 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/eb1d7530ea96
Comment 10 Marco Bonardo [::mak] 2011-10-21 02:12:48 PDT
https://hg.mozilla.org/mozilla-central/rev/eb1d7530ea96

Note You need to log in before you can comment on or make changes to this bug.