Last Comment Bug 692153 - contenteditable=true breaks copy menuitem
: contenteditable=true breaks copy menuitem
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Editor (show other bugs)
: unspecified
: x86 Windows 7
: -- normal with 1 vote (vote)
: ---
Assigned To: neil@parkwaycc.co.uk
:
Mentors:
: 719775 724440 733898 (view as bug list)
Depends on:
Blocks: 676401
  Show dependency treegraph
 
Reported: 2011-10-05 10:20 PDT by dindog
Modified: 2012-06-21 17:02 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
14+
verified


Attachments
testcase (6.49 KB, text/html)
2011-10-05 10:20 PDT, dindog
no flags Details
Proposed patch (5.44 KB, patch)
2011-12-25 16:34 PST, neil@parkwaycc.co.uk
ehsan: review+
lukasblakk+bugs: approval‑mozilla‑esr10+
Details | Diff | Splinter Review

Description dindog 2011-10-05 10:20:52 PDT
Created attachment 564912 [details]
testcase

When there is contenteditable=true element, Copy and Select All menuitem gray-out when selected node is text.

It should block Bug 237964.

It's a regression first appearred in 20110918's nightly.
Comment 1 :Ehsan Akhgari (away Aug 1-5) 2011-10-16 20:55:45 PDT
Alice, can you please see if you can determine a regression range for this?  Thanks!  :-)
Comment 2 Alice0775 White 2011-10-16 21:42:45 PDT
Regression window for the problem of "Copy and Select All menuitem gray-out"

Regression winow(m-c),
Works:
http://hg.mozilla.org/mozilla-central/rev/8b970cb862f2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110817 Firefox/9.0a1 ID:20110818000349
Fails:
http://hg.mozilla.org/mozilla-central/rev/f69a10f23bf3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110818 Firefox/9.0a1 ID:20110818030747
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8b970cb862f2&tochange=f69a10f23bf3


Regression winow(m-i),
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e6d269bc23b9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110817 Firefox/9.0a1 ID:20110817074955
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/05268baefef7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110817 Firefox/9.0a1 ID:20110817115336
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e6d269bc23b9&tochange=05268baefef7

Suspected bug:
Bug 676401 - The queryCommandEnabled API doesn't take the active editing host into account
Comment 3 dindog 2011-11-24 08:26:49 PST
any news about this bug?
It affects Fx9+(current beta), if we don't fix it in Fx11, users have to wait at least 3*6=18 weeks before thay can copy text in those page again...
Comment 4 Mozilla RelEng Bot 2011-12-24 18:00:55 PST
Try run for c1e1cdb0e7d6 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=c1e1cdb0e7d6
Results (out of 207 total builds):
    success: 160
    warnings: 46
    failure: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/neil@parkwaycc.co.uk-c1e1cdb0e7d6
Comment 5 Alice0775 White 2011-12-24 18:12:29 PST
The try server build seems to fix only "Copy".

"Select All" is still broken....
Comment 6 neil@parkwaycc.co.uk 2011-12-25 09:52:51 PST
(In reply to Alice White from comment #5)
> The try server build seems to fix only "Copy".
> 
> "Select All" is still broken....

It was only supposed to fix "Copy". I really wanted to see how many tests fail.
Comment 7 neil@parkwaycc.co.uk 2011-12-25 14:25:24 PST
OK, new approach coming up, this one seems to fix both Copy and Select All :-)
Comment 8 neil@parkwaycc.co.uk 2011-12-25 16:34:20 PST
Created attachment 584296 [details] [diff] [review]
Proposed patch

Fortunately Copy and Select All aren't affected by caret browsing.
Comment 9 Mozilla RelEng Bot 2011-12-25 18:20:24 PST
Try run for fb3e6d2977ae is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=fb3e6d2977ae
Results (out of 209 total builds):
    success: 172
    warnings: 37
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/neil@parkwaycc.co.uk-fb3e6d2977ae
Comment 10 Mozilla RelEng Bot 2011-12-25 19:40:27 PST
Try run for 54a00d6d26c2 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=54a00d6d26c2
Results (out of 24 total builds):
    success: 22
    warnings: 2
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/neil@parkwaycc.co.uk-54a00d6d26c2
Comment 11 :Ehsan Akhgari (away Aug 1-5) 2011-12-29 12:04:06 PST
Comment on attachment 584296 [details] [diff] [review]
Proposed patch

When I was writing https://bugzilla.mozilla.org/attachment.cgi?id=560350, I knew that I had seen a separate bug on this somewhere!  :-)

r=me
Comment 12 neil@parkwaycc.co.uk 2011-12-30 11:49:15 PST
Pushed changeset 4dd80e8ee29e to mozilla-central.
Comment 13 Alice0775 White 2012-01-20 07:02:31 PST
*** Bug 719775 has been marked as a duplicate of this bug. ***
Comment 14 Alice0775 White 2012-02-05 20:02:31 PST
*** Bug 724440 has been marked as a duplicate of this bug. ***
Comment 15 Alice0775 White 2012-03-07 15:37:56 PST
*** Bug 733898 has been marked as a duplicate of this bug. ***
Comment 16 James Pearson 2012-06-08 02:37:54 PDT
This bug is also in Firefox ESR 10.0

This bug is not critical or high, nor causes a crash, but a regression that appeared in v9.0 and was fixed in v12.0.

It results in unpredictable behaviour for users when trying to copy text from webpages - sometimes the copy menu is greyed out, sometimes it is not

The patch that fixes this bug applies cleanly to the 10.0 ESR source (and does indeed fix the issue for 10.0 ESR)

I would appreciated it if this patch can be applied to the ESR tree
Comment 17 Lukas Blakk [:lsblakk] use ?needinfo 2012-06-14 15:28:30 PDT
[Triage Comment]
Looks like a low-risk fix and we're happy to take the occasional usability fix when requested by actual users so please go ahead and nominated for ESR landing.
Comment 18 :Ehsan Akhgari (away Aug 1-5) 2012-06-14 15:47:03 PDT
Comment on attachment 584296 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
User impact if declined: See comment 16.
Fix Landed on Version: Firefox 12.
Risk to taking this patch (and alternatives if risky): Shouldn't be too risky.
String or UUID changes made by this patch:  None.
Comment 19 neil@parkwaycc.co.uk 2012-06-16 15:32:51 PDT
Pushed mozilla-esr10 changeset 445a090fef3f.
Comment 20 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-21 17:02:56 PDT
Verified fixed in Firefox 10.0.6esrpre 2012-06-21 using the attached testcase.

Note You need to log in before you can comment on or make changes to this bug.