nsWindowsShellService's ShortcutMaintenance can be removed ~ 6/12

RESOLVED FIXED in Firefox 56

Status

()

Firefox
Shell Integration
RESOLVED FIXED
6 years ago
11 days ago

People

(Reporter: jimm, Assigned: rstrong)

Tracking

(Blocks: 2 bugs)

Trunk
Firefox 56
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Taskbar app registration is being upgraded in bug 577867 to use a more constant id. The code in ShortcutMaintenance upgrades this id when we do a major upgrade which will not be needed after bug 577867 lands *and* most of our users upgrade to that version.
Note that this affects Thunderbird too.

Should we do this? I think we should keep the code so that we do it one last time.
(Reporter)

Comment 2

6 years ago
(In reply to Siddharth Agarwal [:sid0] from comment #1)
> Note that this affects Thunderbird too.
> 
> Should we do this? I think we should keep the code so that we do it one last
> time.

Note, per the bug title, 6/2012 is the target date of this work. By then active users should be upgraded.
No longer depends on: 577867
Depends on: 577867
Duplicate of this bug: 1370894
Jim, are you still planning on fixing this bug? If not, just un-assign it from yourself. Thanks
Flags: needinfo?(jmathies)
Blocks: 1370647
Created attachment 8875884 [details] [diff] [review]
patch rev1
Assignee: jmathies → robert.strong.bugs
Status: NEW → ASSIGNED
Flags: needinfo?(jmathies)
Pushed to try
https://treeherder.mozilla.org/#/jobs?repo=try&revision=e83e60994efacefe6b114b912b617edccd847292
Created attachment 8875894 [details] [diff] [review]
patch rev1

My repo wasn't current
Attachment #8875884 - Attachment is obsolete: true
Comment on attachment 8875894 [details] [diff] [review]
patch rev1

Try is almost complete and it looks fine. I'll land this after the merge since we are currently in a soft freeze.

Jim, are you ok with reviewing this? The additional includes I removed were added for clearing prefetch files which was removed a long time ago.
Attachment #8875894 - Flags: review?(jmathies)
Matt, just a heads up that this will be removed in the near future and that the helper.exe command line option can be removed.
Flags: needinfo?(mhowell)
(Reporter)

Updated

15 days ago
Attachment #8875894 - Flags: review?(jmathies) → review+

Updated

15 days ago
Blocks: 1371687
Thanks; filed bug 1371687.
Flags: needinfo?(mhowell)

Comment 11

12 days ago
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1c26e57c1899
Remove nsWindowsShellService's ShortcutMaintenance method and calls now that it is no longer needed. r=jimm

Comment 12

11 days ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1c26e57c1899
Status: ASSIGNED → RESOLVED
Last Resolved: 11 days ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
You need to log in before you can comment on or make changes to this bug.