Last Comment Bug 693311 - JM: Wrong result with !==
: JM: Wrong result with !==
Status: RESOLVED FIXED
[inbound][qa+][qa!:10]
: regression, testcase, verified-beta
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla10
Assigned To: Jan de Mooij [:jandem]
:
: Jason Orendorff [:jorendorff]
Mentors:
: 693166 (view as bug list)
Depends on:
Blocks: 690974 693166
  Show dependency treegraph
 
Reported: 2011-10-10 08:16 PDT by Jan de Mooij [:jandem]
Modified: 2012-01-04 00:17 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
Patch (1.34 KB, patch)
2011-10-10 08:33 PDT, Jan de Mooij [:jandem]
wmccloskey: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] 2011-10-10 08:16:40 PDT
--
function f(x) {
    print("foo" !== x);
}
f(1);
f(1);
--
./js -m -n -a test.js
true
false <- should be true
Comment 1 Jan de Mooij [:jandem] 2011-10-10 08:33:37 PDT
Created attachment 565944 [details] [diff] [review]
Patch
Comment 2 Bill McCloskey (:billm) 2011-10-10 08:37:12 PDT
Comment on attachment 565944 [details] [diff] [review]
Patch

Thanks!
Comment 4 Marco Bonardo [::mak] 2011-10-11 02:29:12 PDT
https://hg.mozilla.org/mozilla-central/rev/58c9046d8485
Comment 5 Jan de Mooij [:jandem] 2011-10-12 08:54:19 PDT
*** Bug 693166 has been marked as a duplicate of this bug. ***
Comment 6 Paul Silaghi, QA [:pauly] 2012-01-04 00:17:02 PST
http://www.tvguide.com/Listings/ looks fine now.
This is verified fixed on Firefox 10 Beta2:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (X11; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0) Gecko/20100101 Firefox/10.0

Note You need to log in before you can comment on or make changes to this bug.