Closed Bug 694186 Opened 8 years ago Closed 4 years ago

Inconsistent display of icons

Categories

(Firefox Graveyard :: Panorama, defect)

7 Branch
x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: gm.exducere, Unassigned)

References

Details

Beginning with the introduction of tab groups in FF 6, icons that appear on the main screen's tab bar(s) do not reliably appear on the tab groups screen. There's no apparent reason why some do and some don't, and there's no dependable work-around.

I have two app tabs: gmail and facebook. Their icons are always displayed on the main screen. However, when I switch to the tab groups screen, the facebook icon always appears, while gmail is represented by the generic blank icon. If I click on the generic icon for gmail, it works as expected, opening the gmail tab in that group. But the real gmail icon appears only after returning to the main (tab bar) screen.

Nor is the problem limited to app tabs. My ordinary PayPal and eBay tabs always display their icons on the tab groups screen, while my ordinary Bank of America and Netflix tabs never do. As a web developer, I find it especially galling that icons for pages accessed via the file:// protocol *never* appear on the tab groups screen. This seems to be a matter of deliberate design, because no icon at all is displayed for such pages, not even the generic one. (I have *lots* of tabs, in *many* groups, and I like to give my code a thorough local test before going live. This involves a great deal of switching between tabs, and it helps if I can see their icons before I click on them.)

A related (or perhaps unrelated) issue is that when I replace HTML and icon files on my web server by uploading new versions, the icon may or may not display, even on the main tab bar, no matter how many times I hit the reload button. I know the files are properly installed, because the code works fine -- and the icon displays properly -- on Chrome and Explorer. In fact, everything works fine when I simply switch users and run the exact same binary (C:\Program Files\Mozilla Firefox\firefox.exe) from a different login. Sometimes I can get an icon to display by replacing its dot-ico file with another file having a different size, or a later time stamp. Sometimes I can force Firefox to recognize the new icon file by clearing the browser cache. But there's no sure-fire, never-fail fix.

My web host is a Unix server, and I'm keenly aware of case-sensitivity issues. Also, for unknown reasons, the host's clock is set a couple of hours slow (or else the CFTIME variable isn't correctly set in httpd). I don't have the power to fix that, but it doesn't bother Chrome or Explorer. (For what it's worth, the Firefox Web Developer console shows that a GET operation isn't even attempted on my dot-ico file.)

In my preferences, I disable all history -- browsing history, download history, search history, password history -- and I disable cookies from all sites, except for about a dozen that I expressly list. (The list includes mozilla.org, mozilla.com, and google.com.) Since running the same binary as another user fixes the problem, there must be some cache, or some history list, that I'm not clearing. But it definitely isn't the main cache accessible via Options/Advanced/Network.

I'm running FF 7.0.1 on Win Vista SP2.
Can you also see bug 684609?
Component: General → Panorama
QA Contact: general → panorama
I've just read #684609, which I hadn't seen before. Though it's not exactly the same as my issue, it could well be related.

I never get an actual wrong icon, except in the sense that displaying the generic icon is "wrong" when the legitimate one is available. But displaying, say, the PayPal icon on eBay's tab, no -- I've never encountered that.

My OS is different, too, though I wouldn't imagine that the icon handler is a highly #ifdef'ed part of the code base. But remember that I reported a second issue -- failure to display an icon after replacing or renaming the icon file (not fixable by simply clearing cache). Like #684609, this could be part of a related group of bugs.

This issue arose with the advent of the tab-group feature, and I'm pretty sure it was there from day one. I update faithfully whenever I get nudged by one of the popup-bots, and at first I thought that the bug would soon go away in the normal course of maintenance. But that hasn't happened.

Would a screen snapshot help any? Should I report the cache-clearing bug as a separate issue?
Bug 684609 is only about wrong icon on a new empty tab, not wrong icon on a real page.

Which cache-clearing bug do you mean?
Sorry, I should have split this in two. I thought there might be some connection, but I had been coding all day and I obviously wasn't thinking very well. Mea culpa!

Please refer to my original report, about halfway through, beginning with the words "A related (or perhaps unrelated) issue".
There are actually 3 issues. Also the "no icon with file:// files". If you could file also that one separately, that one should be easy to test (attach sample HTML file with favicon).
1) Some icons are not shown in Panorama when "Remember my browsing history" is unchecked in Options > Privacy.
The Panorama is using favicon service to get the favicons, however, the service depends on the fav icons stored in history.  However, disabling history would affect your fav icons. 

2) no icon with file:// files
The patch for Bug 678374 touches the icons code which should also fix
Depends on: 678374
Status: UNCONFIRMED → NEW
Ever confirmed: true
Is there a plan to separate the favicons from history so that this does not happen?
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.