keyboard shortcut for opening/closing sidebar that works on mac

RESOLVED FIXED in seamonkey2.26

Status

SeaMonkey
Sidebar
--
enhancement
RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: jkng, Assigned: stefanh)

Tracking

Trunk
seamonkey2.26
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; 0.8) Gecko/20010219
BuildID:    2001021904

A shortcut key combo would be a nice enhancement. 

Reproducible: Always
Steps to Reproduce:
use ctrl+ designated key
I believe the F9 key will open and close the sidebar...
OS: Windows 98 → All
Hardware: PC → All

Comment 2

17 years ago
F9 only hides or shows the sidebar (acts as View->My Sidebar) but does not open
or close it. If you have already collapsed the sidebar with the collapse button
on the splitter, it does not show it. Instead, it makes the left border shrink.
It would be nice if F9 with the sidebar collapsed would show it.

Another odd side effect of using F9 is that it makes the spacebar scroll the
page even when typing in a text field. It must steal focus to something other
than the page. If you click back on the page, space works okay again. I'll see
if this is already logged as a bug and add it if not.
(Reporter)

Comment 3

17 years ago
If you drag open the sidebar first, pressing  f9 will have the effect of opening 
and closing the sidebar. Although it is in fact just showing and hiding it.

Comment 4

17 years ago
The focus problem has been split off into bug 69506.

I think that F9 should uncollapse the sidebar if it's collapsed.  Should 
pressing F9 again collapse the sidebar or hide it, though?

Comment 5

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Create shortcut key combo for opening/closing sidebar → [RFE] Create shortcut key combo for opening/closing sidebar

Updated

17 years ago
Target Milestone: --- → Future

Comment 6

16 years ago
reassigning matt's old bugs.
Assignee: matt → sgehani

Comment 7

16 years ago
*** Bug 152821 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
There's not enough rationale for implementing this. Use of keyboard
of keyboard shorcut such as this one is almost exclusive to advanced
users, and anyone who knows the F9 shorcut know well enough how to
show / hide sidebar on the fly. This feature helps no one.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Summary: [RFE] Create shortcut key combo for opening/closing sidebar → keyboard shortcut for opening/closing sidebar
What about the mac?  F9 does not work on MacOS for this and never will.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 10

16 years ago
you got a point. In Mac IE I think there's a keyboard shorcut for
showing/hiding side panels, can't recall what. Does anyone knows it?
And is it `standard' in Mac and maybe other systems w/o F9 key?
OS: All → MacOS X
Hardware: All → Macintosh
Whiteboard: see comment #9 for why this should be implemented

Updated

15 years ago
Summary: keyboard shortcut for opening/closing sidebar → keyboard shortcut for opening/closing sidebar that works on mac
Whiteboard: see comment #9 for why this should be implemented
Product: Browser → Seamonkey
(Assignee)

Comment 11

13 years ago
The F9 key is used by Exposé in Panther, see
http://www.apple.com/macosx/features/expose/
Assignee: samir_bugzilla → nobody
Status: REOPENED → NEW
QA Contact: sujay → sidebar
Target Milestone: Future → ---

Comment 12

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 13

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 14

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 15

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 16

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 17

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
(Assignee)

Comment 18

9 years ago
Still valid, the win/nix shortcut (if mac gets it) get overridden by Exposé.
Status: UNCONFIRMED → NEW
(Assignee)

Comment 19

5 years ago
I've looked at what options we have re a replacement key for F9 and I think Cmd-Opt+S is the prefered combo here. This is the key combo for toggling the Finder sidebar and iTunes sidebar.
Assignee: nobody → stefanh
Hardware: PowerPC → x86
(Assignee)

Comment 20

4 years ago
Created attachment 816368 [details] [diff] [review]
Use Cmd+Opt+S (and add same shortcut in Address book)

I have another patch that relies on each platform-specific overlay, but this one is simpler - it looks like we can override the win/nix shortcuts (keycode's) with the mac-specific keys. This patch also adds F9/Cmd+Opt+S to Address Book (toggle the directory pane).
Attachment #816368 - Flags: superreview?(neil)
Attachment #816368 - Flags: review?(mnyromyr)
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
Comment on attachment 816368 [details] [diff] [review]
Use Cmd+Opt+S (and add same shortcut in Address book)

I would have a slight preference for the version that moved the F9 key to the platform overlay.

>+  <key id="showHideSidebar" key="&showHideSidebarCmd.key;" modifiers="accel, alt"/>
>+
>+  <key id="key_toggleDirectoryPane" key="&toggleDirectoryPaneCmd.key;" modifiers="accel, alt"/>
>+
>+  <key id="key_toggleFolderPane" key="&toggleFolderPaneCmd.key;" modifiers="accel, alt"/>
42 people use a space, 80 people don't. 10 versus 27 if you limit it to suite. (And yes, this file is one of the four in suite that already uses a space in one of its modifiers, so that's another argument...)
Attachment #816368 - Flags: superreview?(neil) → superreview+
(Assignee)

Comment 22

4 years ago
Created attachment 816696 [details] [diff] [review]
New version

(In reply to neil@parkwaycc.co.uk from comment #21)
> I would have a slight preference for the version that moved the F9 key to
> the platform overlay.

Fixed.

> 42 people use a space, 80 people don't. 10 versus 27 if you limit it to
> suite. (And yes, this file is one of the four in suite that already uses a
> space in one of its modifiers, so that's another argument...)

Hmm. Let's let Karsten decide :-)
Attachment #816696 - Flags: review?(mnyromyr)
(Assignee)

Updated

4 years ago
Attachment #816368 - Flags: review?(mnyromyr)

Comment 23

4 years ago
Comment on attachment 816696 [details] [diff] [review]
New version

I'd prefer the modifiers without spaces too. Code looks good otherwise.
I've been testing on Linux, so assuming you have tested on a mac r=me
Attachment #816696 - Flags: review?(mnyromyr) → review+
(Assignee)

Comment 24

4 years ago
Landed without spaces: http://hg.mozilla.org/comm-central/rev/45ad1b4359c1
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.26
You need to log in before you can comment on or make changes to this bug.