Last Comment Bug 697659 - Use doorhangers for Password Manager
: Use doorhangers for Password Manager
Status: VERIFIED FIXED
: feature
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
: P2 normal (vote)
: ---
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
Mentors:
Depends on: 700913 718705 718708
Blocks: 695446
  Show dependency treegraph
 
Reported: 2011-10-26 21:36 PDT by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2012-01-17 09:41 PST (History)
6 users (show)
camelia.urian: in‑litmus+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
WIP 1 (9.83 KB, patch)
2011-11-01 22:41 PDT, Mark Finkle (:mfinkle) (use needinfo?)
no flags Details | Diff | Splinter Review
patch (9.19 KB, patch)
2011-11-15 19:31 PST, Mark Finkle (:mfinkle) (use needinfo?)
margaret.leibovic: review+
Details | Diff | Splinter Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2011-10-26 21:36:29 PDT
Baseline password/login manager landed using the prompt system. We need to add support for using doorhangers next.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-01 22:41:28 PDT
Created attachment 571244 [details] [diff] [review]
WIP 1

This patch makes the basic changes to LoginManagerPrompter.js to support using the new NativeWindow.doorhanger API.

The main thing yet to add is the concept of a "timeout" or "persistence" to a doorhanger. Normally, we remove doorhangers on pageload, but with password doorhangers, a page load is expected (to the login OK or invalid page) so we shouldn't dismiss the doorhanger right a way.

Will add that support to Doorhanger next.
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-15 19:31:57 PST
Created attachment 574778 [details] [diff] [review]
patch

This patch converts the Fennec LoginManagerPrompter.js from using "notificationbox" API to use "doorhanger" API. I tried to change as little code as possible. We just work to get the NativeWindow object instead of the notifyBox.

I use the new persistence and timeout doorhanger features to mimic the same behavior in Fennec as found on desktop.

(I was having a problem while testing this patch. The doorhanger didn't want to dismiss after tapping a button. Updating my source tree to get the latest patches fixed that issue.)
Comment 3 :Margaret Leibovic 2011-11-16 11:04:32 PST
Comment on attachment 574778 [details] [diff] [review]
patch

We should probably update all the comments that talk about showing notification bars, since we don't do that anymore.
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-16 13:19:45 PST
I updated some of the "notification bar" comments to "notification doorhanger", but left the function names as is

https://hg.mozilla.org/projects/birch/rev/add4665a783d
Comment 5 Camelia Urian 2011-11-30 07:23:10 PST
Test case:
https://litmus.mozilla.org/show_test.cgi?id=33925
Comment 6 Camelia Urian 2011-11-30 07:24:17 PST
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:11.0a1) Gecko/20111130 Firefox/11.0a1 Fennec/11.0a1
Device: HTC Desire Z
OS: Android 2.3

Door hangers are used for password manager.

Note You need to log in before you can comment on or make changes to this bug.