[traceback] KeyError: 2L

VERIFIED FIXED in 6.3.1

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
P2
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: kumar)

Tracking

unspecified
6.3.1

Details

(URL)

(Reporter)

Description

7 years ago
steps to reproduce:
1. Load https://addons-dev.allizom.org/z/en-US/admin/models/addons/compatoverride/2/
2. Add a new application to the compat list with "*" as the value and save changes.
3. Load https://addons-dev.allizom.org/z/en-US/firefox/api/1.5/search/guid:piclens@cooliris.com


traceback details:
KeyError on celery-dev1.addons.phx1.mozilla.com

File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/addons-dev.allizom.org/zamboni/apps/api/views.py", line 212, in guid_search
    'api_version': api_version, 'api': api})

  File "/data/www/addons-dev.allizom.org/zamboni/apps/api/views.py", line 61, in render_xml
    rendered = template.render(**context)

  File "/usr/lib64/python2.6/site-packages/jinja2/environment.py", line 891, in render
    return self.environment.handle_exception(exc_info, True)

  File "/data/www/addons-dev.allizom.org/zamboni/apps/api/templates/api/search.xml", line 6, in top-level template code
    {% if compat %}{% include 'api/compat.xml' %}{% endif %}

  File "/data/www/addons-dev.allizom.org/zamboni/apps/api/templates/api/compat.xml", line 8, in top-level template code
    {% for vr in c.collapsed_ranges() %}

  File "/data/www/addons-dev.allizom.org/zamboni/apps/addons/models.py", line 1608, in collapsed_ranges
    app = AppRange(amo.APP_IDS[compat.app_id],
Duplicate of this bug: 699309
(Reporter)

Updated

7 years ago
Summary: [traceback] KeyError- app = AppRange(amo.APP_IDS[compat.app_id], → [traceback] KeyError: 2L
Fixed: https://github.com/mozilla/zamboni/commit/c1067c6b36fbb81d541c8e805cea61ecec2489d1
Assignee: nobody → kumar.mcmillan
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Priority: -- → P2
Resolution: --- → FIXED
Target Milestone: --- → 6.3.1
(Reporter)

Comment 4

7 years ago
verified at https://addons-dev.allizom.org/z/en-US/admin/models/addons/compatoverride/
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.