Last Comment Bug 700246 - The color of some toolbar icons goes to white (inverted) with a dark persona
: The color of some toolbar icons goes to white (inverted) with a dark persona
Status: RESOLVED FIXED
fixed by bug 735691
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: 8 Branch
: x86 Windows XP
: -- normal (vote)
: Firefox 14
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 735691
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-07 01:50 PST by Ferenc Magyar
Modified: 2012-03-29 00:35 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
ff_icons_bug.jpg (47.20 KB, image/jpeg)
2011-11-07 01:50 PST, Ferenc Magyar
no flags Details

Description Ferenc Magyar 2011-11-07 01:50:01 PST
Created attachment 572409 [details]
ff_icons_bug.jpg

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

Apply a dark colored persona, for example: http://www.getpersonas.com/en-US/persona/44305


Actual results:

The color of some icons on the toolbar (open new tab, group your tabs, list all tabs) goes to white (inverted). See the attached image.


Expected results:

The color of the above listed icons should stay in default color after applying a dark colored persona.
Comment 1 Wes Kocher (:KWierso) 2011-11-08 23:57:17 PST
I only see this when those buttons are housed on the navigation toolbar. On the tab toolbar, they all stay the same color.
Comment 2 ffextensionguru 2011-11-09 21:14:14 PST
This is normal behavior per Bug 671553
Comment 3 ffextensionguru 2011-11-09 21:18:32 PST
However, I should add that this is not ideal and looks goofy. I did create a stylish script [http://userstyles.org/styles/56094/firefox-8-un-white-toolbar-buttons?r=1320900717] to 'fix' this. However, it does not restore the actual button or glow effect though
Comment 4 Stephen Horlander [:shorlander] 2011-11-10 06:18:38 PST
(In reply to Al Hutchison from comment #2)
> This is normal behavior per Bug 671553

All the icons not living in a button should either be normal or inverted depending on if the persona is light or dark. So having two icons randomly inverted is not intended.
Comment 5 Siddhartha Dugar [:sdrocking] 2012-03-21 11:40:50 PDT
Using a build with Bug 735691 fixed, on the default theme with tabs on bottom the panorama button in the nav-bar stays dark instead of being inverted. This needs to be fixed.
Comment 6 Siddhartha Dugar [:sdrocking] 2012-03-25 21:21:38 PDT
(In reply to Siddhartha Dugar [:sdrocking] from comment #5)
> Using a build with Bug 735691 fixed, on the default theme with tabs on
> bottom the panorama button in the nav-bar stays dark instead of being
> inverted. This needs to be fixed.

Bug 679801 fixed this!

Note You need to log in before you can comment on or make changes to this bug.