SeaMonkey doesn't start (stops during startup). No Breakpad dialog.

VERIFIED FIXED

Status

SeaMonkey
Startup & Profiles
--
critical
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: tonymec, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Trunk
regression

SeaMonkey Tracking Flags

(seamonkey2.7+ fixed)

Details

Reproducible: Always

SeaMonkey stops during startup. No Breakpad dialog. If invoked with -ProfileManager, it happens after clicking "Start SeaMonkey" to end PM operations.

Last good build from Mozilla:
Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111017 Firefox/10.0a1 SeaMonkey/2.7a1 ID:20111017003001

Last good own-built build:
Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111106 Firefox/10.0a1 SeaMonkey/2.7a1 ID:20111106104605
Alas, I don't have it anymore.

First bad own-built build (seamonkey-*.txt):
20111107090237
http://hg.mozilla.org/mozilla-central/rev/161c6106d787

First bad build from Mozilla: today's nightly. Its seamonkey-*.txt is:
20111107003001
http://hg.mozilla.org/mozilla-central/rev/161c6106d787

Between Oct.17 and today the SeaMonkey L64 builders were down.
P.P.S. I am on CET, i.e. UTC+0200.
Component: General → Startup & Profiles
QA Contact: general → profile-manager
P.P.P.S. No window opened. A few messages on stdout/stderr but they also happen in "good" builds. Here they are:


(seamonkey-bin:6756): GLib-GObject-WARNING **: plugin '/usr/lib64/gtk-2.0/immodules/im-scim.so' failed to register type 'GtkIMContextSCIM'


(seamonkey-bin:6756): Gtk-WARNING **: Loading IM context type 'scim' failed

(seamonkey-bin:6756): GLib-GObject-WARNING **: plugin '/usr/lib64/gtk-2.0/immodules/im-scim.so' failed to register type 'GtkIMContextSCIM'


(seamonkey-bin:6756): Gtk-WARNING **: Loading IM context type 'scim' failed



If I run the Profile Manager, there are more messages, but of the same kind.

Comment 5

6 years ago
Don't know why my former comment hasn't made it to Bugzilla, but i will try to reproduce.

This bug could be the same i have seen in my last build some hours ago. SM did not start but could forced with 'seamonkey -mail'. MailNews operates normally but starting the browser from within MailNews fails with this message from the error console:

Error: uncaught exception: [Exception... "Component returned failure
code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)
[nsIJSCID.getService]"  nsresult: "0x80570016
(NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame ::
chrome://communicator/content/tasksOverlay.js :: OpenBrowserWindow ::
line 169"  data: no]

Comment 6

6 years ago
If I start 'seamonkey -jsconsole', I get

> Error: missing ) after argument list
> Source File: jar:file:///C:/Users/Johler/Util/Internet/Seamonkey.own.err/omni.jar!/components/nsBrowserContentHandler.js
> Line: 192, Column: 35
> Source Code:
>                                    nsISupportsString).data); 

Seems like the code in 'nsBrowserContentHandler.js', line 191 should read:
>       return prefs.getComplexValue("browser.history.last_page_visited",
>                                    nsISupportsString).data;
instead of
>      return prefs.getComplexValue("browser.history.last_page_visited"
>                                   nsISupportsString).data);
(In reply to H. Hofer from comment #6)
> If I start 'seamonkey -jsconsole', I get
> 
> > Error: missing ) after argument list
> > Source File: jar:file:///C:/Users/Johler/Util/Internet/Seamonkey.own.err/omni.jar!/components/nsBrowserContentHandler.js
> > Line: 192, Column: 35
> > Source Code:
> >                                    nsISupportsString).data); 
> 
> Seems like the code in 'nsBrowserContentHandler.js', line 191 should read:
> >       return prefs.getComplexValue("browser.history.last_page_visited",
> >                                    nsISupportsString).data;
> instead of
> >      return prefs.getComplexValue("browser.history.last_page_visited"
> >                                   nsISupportsString).data);

Ugh that is surely it. r+a+=me for *someone* landing that ASAP.

regression from http://hg.mozilla.org/comm-central/rev/a3b479f82595
tracking-seamonkey2.7: ? → +
(Assignee)

Comment 9

6 years ago
Yeah, totally my fault. Sorry about that.
Assignee: nobody → neil
Blocks: 692423
Status: NEW → RESOLVED
Last Resolved: 6 years ago
OS: Linux → All
Hardware: x86_64 → All
Resolution: --- → FIXED

Updated

6 years ago
Duplicate of this bug: 700360
Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111107 Firefox/10.0a1 SeaMonkey/2.7a1 ID:20111107193531

This tinderbox-build starts up normally again.
Status: RESOLVED → VERIFIED

Updated

6 years ago
status-seamonkey2.7: affected → fixed
You need to log in before you can comment on or make changes to this bug.