Last Comment Bug 701005 - Permanent orange: TEST-UNEXPECTED-FAIL | test-header-toolbar.js | test_customize_header_toolbar_reorder_buttons, test_customize_header_toolbar_separate_window, test_customize_header_toolbar_remove_buttons
: Permanent orange: TEST-UNEXPECTED-FAIL | test-header-toolbar.js | test_custom...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Testing Infrastructure (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: Thunderbird 11.0
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 702573 (view as bug list)
Depends on: 701146
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-09 06:40 PST by Mike Conley (:mconley)
Modified: 2011-11-16 02:51 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments

Description Mike Conley (:mconley) 2011-11-09 06:40:48 PST
This just showed up during the dogpile of patches yesterday.  Experience tells me that these three oranges are likely related, hence why I bound them into a single bug.

SUMMARY-UNEXPECTED-FAIL | test-header-toolbar.js | test_customize_header_toolbar_reorder_buttons
  EXCEPTION: a != b: 'hdrReplyToSenderButton,hdrSmartReplyButton,hdrForwardButton,hdrArchiveButton,hdrJunkButton,hdrTrashButton' != 'hdrTrashButton,hdrJunkButton,hdrArchiveButton,hdrForwardButton,hdrSmartReplyButton,hdrReplyToSenderButton'.
    at: test-folder-display-helpers.js line 2842
       assert_true(false,"a != b: 'hdrReplyToSenderButton,hdrSmartReplyButton,hdrForwardButton,hdrArchiveButton,hdrJunkButton,hdrTrashButton' != 'hdrTrashButton,hdrJunkButton,hdrArchiveButton,hdrForwardButton,hdrSmartReplyButton,hdrReplyToSenderButton'.") test-folder-display-helpers.js 2842
       assert_equals("hdrReplyToSenderButton,hdrSmartReplyButton,hdrForwardButton,hdrArchiveButton,hdrJunkButton,hdrTrashButton","hdrTrashButton,hdrJunkButton,hdrArchiveButton,hdrForwardButton,hdrSmartReplyButton,hdrReplyToSenderButton") test-folder-display-helpers.js 2829
       test_customize_header_toolbar_reorder_buttons() test-header-toolbar.js 195
            frame.js 554
            frame.js 623
            frame.js 666
            frame.js 494
            frame.js 672
            server.js 182
            server.js 186

SUMMARY-UNEXPECTED-FAIL | test-header-toolbar.js | test_customize_header_toolbar_separate_window
  EXCEPTION: a != b: 'hdrReplyToSenderButton,hdrSmartReplyButton,hdrForwardButton,hdrArchiveButton,hdrJunkButton,hdrTrashButton' != 'hdrTrashButton,hdrJunkButton,hdrArchiveButton,hdrForwardButton,hdrSmartReplyButton,hdrReplyToSenderButton'.
    at: test-folder-display-helpers.js line 2842
       assert_true(false,"a != b: 'hdrReplyToSenderButton,hdrSmartReplyButton,hdrForwardButton,hdrArchiveButton,hdrJunkButton,hdrTrashButton' != 'hdrTrashButton,hdrJunkButton,hdrArchiveButton,hdrForwardButton,hdrSmartReplyButton,hdrReplyToSenderButton'.") test-folder-display-helpers.js 2842
       assert_equals("hdrReplyToSenderButton,hdrSmartReplyButton,hdrForwardButton,hdrArchiveButton,hdrJunkButton,hdrTrashButton","hdrTrashButton,hdrJunkButton,hdrArchiveButton,hdrForwardButton,hdrSmartReplyButton,hdrReplyToSenderButton") test-folder-display-helpers.js 2829
       test_customize_header_toolbar_separate_window() test-header-toolbar.js 252
            frame.js 554
            frame.js 623
            frame.js 666
            frame.js 494
            frame.js 672
            server.js 182
            server.js 186

SUMMARY-UNEXPECTED-FAIL | test-header-toolbar.js | test_customize_header_toolbar_remove_buttons
  EXCEPTION: a != b: '__empty' != 'hdrReplyToSenderButton,hdrSmartReplyButton,hdrForwardButton,hdrArchiveButton,hdrJunkButton,hdrTrashButton'.
    at: test-folder-display-helpers.js line 2842
       assert_true(false,"a != b: '__empty' != 'hdrReplyToSenderButton,hdrSmartReplyButton,hdrForwardButton,hdrArchiveButton,hdrJunkButton,hdrTrashButton'.") test-folder-display-helpers.js 2842
       assert_equals("__empty","hdrReplyToSenderButton,hdrSmartReplyButton,hdrForwardButton,hdrArchiveButton,hdrJunkButton,hdrTrashButton") test-folder-display-helpers.js 2829
       test_customize_header_toolbar_remove_buttons() test-header-toolbar.js 358
            frame.js 554
            frame.js 623
            frame.js 666
            frame.js 494
            frame.js 672
            server.js 182
            server.js 186
Comment 1 Mike Conley (:mconley) 2011-11-09 12:47:35 PST
So this is a platform bug - see bug 701146.
Comment 2 Mike Conley (:mconley) 2011-11-12 08:22:07 PST
Patch for 701146 landed last night as https://hg.mozilla.org/mozilla-central/rev/0ad06b88a36b

Just waiting on Aurora approval now.
Comment 3 Mike Conley (:mconley) 2011-11-15 06:20:33 PST
*** Bug 702573 has been marked as a duplicate of this bug. ***
Comment 4 Mike Conley (:mconley) 2011-11-15 15:17:57 PST
Patch for 701146 just landed in Aurora:  https://hg.mozilla.org/releases/mozilla-aurora/rev/81e7a0f84279

Note You need to log in before you can comment on or make changes to this bug.