Closed Bug 701287 Opened 8 years ago Closed 8 years ago

Firefox 8 breaks tab icons

Categories

(Firefox :: Tabbed Browser, defect)

8 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 701297
Tracking Status
firefox8 - ---
firefox9 - ---

People

(Reporter: theunk7, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

I upgraded to Firefox 8


Actual results:

those little icons on the tabs don't show for many sites that DEFINITELY have them (Firefox 7 saw them IE & Chrome see/show them).  Originally I thought they were small and would be hard to see, but I was amazed how instinctive they made tab jumping.

Refreshing window doesn't correct it

  Theoretically their no big deal ... ...until you get used to them!!  But of even greater concern is how this version was released with such a glaring flaw.  I used to be sure to keep at least 1-2 years behind years on Firefox upgrades and went the opposite trying to overcome Flash nitemares 


Expected results:

things should not have been clobbered, and worse case a page refresh SHOULD be a page refresh and cover this.

I did see that sites with no icon will now have this weird broken box instead of taking Firefox's logo as default.  If you don't want any sites 'using YOUR logo', almost any graphic would have been better than this.  Choice of default graphic icon should NOT present 'this browser looks broken' feel that your broken box does...
Thanks for reporting this! I can't reproduce this issue myself, but we have received a few reports of it. I'd love it if you could provide a bit more info so that we can try to track down the problem.

Would you be able to try temporarily downgrading to Firefox 7, to see whether the icons re-appear again? If so, could you attach a screenshot of the icons appearing in 7, and one of them being gone in 8?

(You can download Firefox 7 from http://releases.mozilla.org/pub/mozilla.org/firefox/releases/7.0.1/win32/en-US/ )
Are we talking about the new blank document favicon?
Is it that dashed sqore tat disturbs you?
https://bug648668.bugzilla.mozilla.org/attachment.cgi?id=541680

If so that's the new default icon
(see bug 648668, shoulds have been worth relnote or some documentation ...)
I have the same problem with missing bookmark icons.  Only a limited number of icons are affected for specific websites.  Here is an example of a website that causes this problem for me.  I am running firefox 8 with adblock plus and oldbar addons.

http://forums.gardenweb.com/forums/asianveg/

Visit the weblink, add a bookmark, close the page/tab, then look at the bookmark to see if the icon is blank.  It should have a green leaf icon.
(In reply to Darrel Jones from comment #4)
> http://forums.gardenweb.com/forums/asianveg/
The is no icon on the tab when the page loads up, why should the bookmark have one?
I posted this in <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=701297">Bug 701297</a>, which addresses the bookmark favicon issue, but I think that this is actually the bug to which my comments apply.  Please forgive me for the appearance of cross-posting; I truly just found this bug!

Immediately upon upgrading to FF8, I discovered that the dotted square is replacing favicons that do, in fact, exist.  They were all working in FF7 but are now "missing" in FF8.

Take this page, for instance: in the title bar, the Bugzilla favicon appears ( https://bugzilla.mozilla.org/extensions/BMO/web/images/favicon.ico ), but on the tab is the dotted box.  Even Google's favicon is missing; although it is not coded in the HTML, it is sitting in the expected spot ( http://www.google.com/favicon.ico ).

I have discovered that the favicon will appear in the address bar (for sites that have one, whether coded with rel="icon" or in the default root location) after clicking on the "blank" icon beside the address.  (Moving the tab may have the same effect; I am sure that it happened, once, but I have not been able to reproduce it!)

The favicon does not persist, however.  Once the page is reloaded or after clicking a link to another page on the same site, the behaviour repeats ("blank" favicon until clicked).

I have not discovered any way to force the favicon to display on the tab.

I have tested pages that do not have the rel="icon" instruction but do have a default favicon.ico in the site's root, pages that have both a (different or identical) default favicon and a rel="icon" direction, pages that change icons as the site is navigated (different favicons for different pages) and a variety of capitalization ("Icon" "ICON" &c) in the rel="icon" (or rel="shortcut icon") instruction.

The favicon also does not appear in the Page Info / Media preview until you click on another picture and then click back on the favicon entry.  This has no effect on the address bar or tab display, and the favicon sometimes persists and sometimes does not when you exit the Page Info window and open it, again.  I have not figured out if there is any pattern to this latter behaviour.
Bug 701297 is a dup of this or vice versa.
Most of this discussion shoots way over my head.  I take no issue with it being closed as dup of 701297 if you all understand discussion of 201297 and cross post here and believe that's the case.  What I can understand of Peter's additional observations after seeing my posting 701287 sounds like we see the same thing, and I suspect his technical detail to be much more relevant for follow-up so if they are dups, close-dup'ing 701287 makes more sense.
(In reply to theunk7 from comment #8)
> Most of this discussion shoots way over my head.

As per my comments in Bug 701287, did you try Safe Mode and / or disabling potentially conflicting Add Ons like Favicon Picker 2 (which was my problem)?

If so, please report your results, there.
(In reply to theunk7 from comment #8)
> Most of this discussion shoots way over my head.

As per my comments in Bug 701297, did you try Safe Mode and / or disabling potentially conflicting Add Ons like Favicon Picker 2 (which was my problem)?

If so, please report your results, there.
Sorry about the double post.  Is there no "edit" or "delete" feature, here?
> Is there no "edit" or "delete" feature, here?

No, your comment is for all eternity
http://www.mediafire.com/download.php?0bjbyhorijpxkjg
My buttons patch actually seems to fix this (I think).
Can anyone here confirm???
I still don't get what this bug is about, most of the comments refer to Bug 701297. Is this about not being able to tell one tab from another? If you are complaining about the dotted square icon on tabs, wait for Bug 685059. For bookmarks, the new icon doesn't make a difference to the usability.
It seems to be a duplicate of Bug 701297, yes.

I wish https://bugzilla.mozilla.org/show_bug.cgi?id=700972 was getting this same attention.
Edit buttons would be sooooo nice.
My patch for favicon square dotted empty.

http://www.divshare.com/download/16165025-ab2

Download this file, unpack it, and replace the original file omni.jar with omni.jar present in this folder.
This folder contains 4 files omni.jar, for 4 different users.

Patch for:
1. Linux english language.
2. Linux italian language.
3. Windows english language.
4. Windows italian language.

This patch it is only per Firefox 8.0.
For future versions hopefully in an official patch.
Our current understanding of this issue is described at bug 701297 comment 26 - let me know if you think there are other issues not mentioned there.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 701297
You need to log in before you can comment on or make changes to this bug.