Last Comment Bug 701481 - App Tabs lost with current nightly: SessionStore: The session file is invalid: TypeError: this._extractHostsForCookies is not a function
: App Tabs lost with current nightly: SessionStore: The session file is invalid...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
:
: Mike de Boer [:mikedeboer]
Mentors:
: 701171 (view as bug list)
Depends on:
Blocks: 698565 886116
  Show dependency treegraph
 
Reported: 2011-11-10 12:41 PST by Stefan
Modified: 2013-06-23 06:17 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v0.1 (1002 bytes, patch)
2011-11-10 12:50 PST, Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
gavin.sharp: review+
Details | Diff | Splinter Review

Description Stefan 2011-11-10 12:41:25 PST
User Agent:  

Steps to reproduce:

1. Copy a saved profile generated with Fx 9.0a1 into .mozilla.
2. Start nightly 2011-11-10-03-14-03-mozilla-central.


Actual results:

2. App Tabs are lost. Error console says “SessionStore: The session file is invalid: TypeError: this._extractHostsForCookies is not a function”


Expected results:

2. Keep App Tabs.

2011-11-09-03-11-11-mozilla-central is OK.
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6d42793c4807&tochange=c60535115ea1
Comment 1 Jim Jeffery not reading bug-mail 1/2/11 2011-11-10 12:45:16 PST
dupe of 701171 ?
Comment 2 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-10 12:50:57 PST
Created attachment 573607 [details] [diff] [review]
Patch v0.1

I... uhhh... oops.
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-11-10 12:56:01 PST
Comment on attachment 573607 [details] [diff] [review]
Patch v0.1

why didn't tests catch this?
Comment 4 Stefan 2011-11-10 13:00:10 PST
(In reply to Paul O'Shannessy [:zpao] from comment #2)
> Created attachment 573607 [details] [diff] [review] [diff] [details] [review]
> Patch v0.1

Works.

(In reply to Gavin Sharp (use gavin@gavinsharp.com for email) from comment #3)
> why didn't tests catch this?

Can't it be checked automatically? I mean every linker complains on unresolved symbols ...
Comment 5 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-10 13:09:38 PST
*** Bug 701171 has been marked as a duplicate of this bug. ***
Comment 6 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-10 13:15:37 PST
(In reply to Gavin Sharp (use gavin@gavinsharp.com for email) from comment #3)
> Comment on attachment 573607 [details] [diff] [review] [diff] [details] [review]
> Patch v0.1
> 
> why didn't tests catch this?

This is now only in the startup path. And it only affects history entries where there are children entries. When I did my manual testing I used simple pages so I didn't see this. Testing with gmail, I could repro.

Ideally this would be covered by mozmill tests or at least litmus test

(In reply to Stefan from comment #4)
> Can't it be checked automatically? I mean every linker complains on
> unresolved symbols ...

This is in interpreted JS, where we don't have that sort of tool.
Comment 7 chaosfreedom1220 2011-11-10 13:19:18 PST
seems fixed in latest hourly.
Comment 8 chaosfreedom1220 2011-11-10 13:21:09 PST
nevermind... 3+ app tabs nukes it
Comment 9 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-10 13:24:28 PST
(In reply to chaosfreedom1220 from comment #8)
> nevermind... 3+ app tabs nukes it

The fix hasn't been checked in. This bug will be marked RESOLVED FIXED when it is. As I mentioned in comment 6, not all websites will trigger the error - it has nothing to do with how many app tabs you have.
Comment 10 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-10 13:57:23 PST
pushed to inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/23e0d7c97b34
Comment 11 alex_mayorga 2011-11-10 14:27:52 PST
Would I get my "app tabs" back tomorrow or do I start to "pin" the ones I remember of?
Comment 12 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-10 14:31:52 PST
(In reply to alex_mayorga from comment #11)
> Would I get my "app tabs" back tomorrow or do I start to "pin" the ones I
> remember of?

The ones you lost are "lost", though you should be able to load that session tomorrow to get them back. Alternatively, turning on session restore when loading that session should restore them just fine.

For newly pinned tabs in a new session, they should be restored properly in tomorrow's nightly (assuming the above commit gets merged in before nightly builds, which it should). The error happens at startup, not during saving.
Comment 13 Marco Bonardo [::mak] 2011-11-11 02:21:53 PST
https://hg.mozilla.org/mozilla-central/rev/23e0d7c97b34

Note You need to log in before you can comment on or make changes to this bug.