Status

www.mozilla.org
General
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: hub, Assigned: cilias)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

2.33 KB, patch
standard8
: review+
Details | Diff | Splinter Review
(Reporter)

Description

7 years ago
the page http://www.mozilla.org/projects/thunderbird/ is totally out of date.

This page is hit number 2 for "thunderbird" on Google.
It still list 3.1 as the latest thunderbird while we currently are at 8.
Component: Web Site → www.mozilla.org
Product: Mozilla Services → Websites
QA Contact: website → www-mozilla-org
Hardware: x86_64 → All
(Assignee)

Updated

7 years ago
Assignee: nobody → bmo2010
OS: Linux → All
(Assignee)

Comment 1

7 years ago
Created attachment 575360 [details] [diff] [review]
patch1

* I had to get confirmation on IRC that Nightlies are now called "Daily" instead of Shredder. So I changed that list item to say "Daily builds" instead of "Shredder (nightly build)"

* I also added an item under "Historical Releases" for TB 3.0.

I assume this can be checked in without review, but I'd rather have someone from the TB team look at it. (and maybe get an owner for this page)
Attachment #575360 - Flags: review?
(Assignee)

Updated

7 years ago
Attachment #575360 - Flags: review? → review?(mbanner)

Updated

7 years ago
Blocks: 704072
(Assignee)

Updated

7 years ago
Attachment #575360 - Flags: review?(mbanner)
(Assignee)

Comment 2

7 years ago
r98070
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

7 years ago
yep. definitely up to date.
Status: RESOLVED → VERIFIED

Comment 4

7 years ago
Nice. Could you do bug 704072 in a similar way?
Comment on attachment 575360 [details] [diff] [review]
patch1

Sorry I didn't get to this earlier, I have had other priorities this week, and this had been this way for a long time already.

We should either be not listing numbers on that page at all, or having them be generated automatically.

I don't think we need any information about historical releases on this page. If we do, then it should be automatically generated, or on a wiki (we could even point to http://en.wikipedia.org/wiki/History_of_Mozilla_Thunderbird !).

As a solid proposal, I would say that the first section should be the same as Firefox:

http://www.mozilla.org/projects/firefox/

(with the exception that we don't yet have a nightly.mozilla.org link, so just point to ftp).

Apart from that, these links are wrong:

+	<li>Next release: <a href="http://www.mozillamessaging.com/thunderbird/early_releases/downloads/">Thunderbird 9</a></li>

This should be going to http://www.mozilla.org/en-US/thunderbird/channel/ (although if the FF format is followed, this won't matter).

I disagree that we need this listed, if we want people to test, we should be getting them to test the latest versions (and in any case, it should use a mozilla.org link):

+	<li>Previous supported release: <a href="http://www.mozillamessaging.com/en-US/thunderbird/all-older.html">Thunderbird 3.1</a></li>
Attachment #575360 - Flags: review-
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

7 years ago
(In reply to Mark Banner (:standard8) from comment #5)
> Comment on attachment 575360 [details] [diff] [review] [diff] [details] [review]
> patch1
> 
> Sorry I didn't get to this earlier, I have had other priorities this week,
> and this had been this way for a long time already.
> 
> We should either be not listing numbers on that page at all, or having them
> be generated automatically.
> 
> I don't think we need any information about historical releases on this
> page. If we do, then it should be automatically generated, or on a wiki (we
> could even point to
> http://en.wikipedia.org/wiki/History_of_Mozilla_Thunderbird !).

That link is actually in the next section, under "Other History".
Do you want to just remove the entire "Historical Releases" section, and rename the next section to "History"?

> As a solid proposal, I would say that the first section should be the same
> as Firefox:
> 
> http://www.mozilla.org/projects/firefox/
> 
> (with the exception that we don't yet have a nightly.mozilla.org link, so
> just point to ftp).

Do you also want the links to be called "Desktop" like in the Fx page?
(In reply to Chris Ilias [:cilias] from comment #6)
> (In reply to Mark Banner (:standard8) from comment #5)
> > Comment on attachment 575360 [details] [diff] [review] [diff] [details] [review] [diff] [details] [review]
> > patch1
> > 
> > Sorry I didn't get to this earlier, I have had other priorities this week,
> > and this had been this way for a long time already.
> > 
> > We should either be not listing numbers on that page at all, or having them
> > be generated automatically.
> > 
> > I don't think we need any information about historical releases on this
> > page. If we do, then it should be automatically generated, or on a wiki (we
> > could even point to
> > http://en.wikipedia.org/wiki/History_of_Mozilla_Thunderbird !).
> 
> That link is actually in the next section, under "Other History".
> Do you want to just remove the entire "Historical Releases" section, and
> rename the next section to "History"?

Yes, lets do that.

> > As a solid proposal, I would say that the first section should be the same
> > as Firefox:
> > 
> > http://www.mozilla.org/projects/firefox/
> > 
> > (with the exception that we don't yet have a nightly.mozilla.org link, so
> > just point to ftp).
> 
> Do you also want the links to be called "Desktop" like in the Fx page?

Ah, good point. I think for now, lets drop the Desktop word and just linkify the Nightly / EarlyBird / Beta / Current Release words. Note I've explicitly said EarlyBird as that's the public-visible name for the TB aurora based channel.

Comment 8

7 years ago
Thunderbird's Nightlies are called "Daily".
(Assignee)

Comment 9

7 years ago
Created attachment 578430 [details] [diff] [review]
patch2

- Renamed "Current Releases" to "Release Channels"
- Ordered it Daily builds-->Current Release
- Used FTP link for "Daily builds", channels link for EarlyBird and Beta
- Linkified the channel names (instead of using the word "desktop")
- Removed "History Releases" section
- Renamed "Other History" to "History"
Attachment #575360 - Attachment is obsolete: true
Attachment #578430 - Flags: review?(mbanner)
Comment on attachment 578430 [details] [diff] [review]
patch2

This looks great. Thanks for updating this.
Attachment #578430 - Flags: review?(mbanner) → review+
Excellent. Thanks Chris.

Updated

7 years ago
Duplicate of this bug: 692289
(Assignee)

Comment 13

7 years ago
r98368
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Thanks Chris, that looks much better :-)
Status: RESOLVED → VERIFIED

Comment 15

7 years ago
Now I see the new version of the page. Shouldn't it at least mention somewhere what Thunderbird actually is? There is no word that it is an email client. Is that a problem?
Duplicate of this bug: 685153
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.