Last Comment Bug 701834 - Missing favicons for some sites
: Missing favicons for some sites
Status: VERIFIED FIXED
[testday-20111111]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
P2 normal (vote)
: ---
Assigned To: Brian Nicholson (:bnicholson)
:
: Sebastian Kaspari (:sebastian)
Mentors:
http://getfirebug.com
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-11 13:10 PST by Dave Hunt (:davehunt)
Modified: 2016-07-29 14:20 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch (844 bytes, patch)
2011-11-11 16:14 PST, Brian Nicholson (:bnicholson)
mark.finkle: review+
Details | Diff | Splinter Review

Description User image Dave Hunt (:davehunt) 2011-11-11 13:10:39 PST
I noticed that a few sites aren't displaying favicons. The common factor is that the rel attribute for the <link> is 'shortcut icon' rather than just 'icon'.

Steps to reproduce:
1. Load getfirebug.com or docs.python.org

Expected result:
Favicon is displayed in the awesomebar

Actual result:
No favicon is displayed in the awesomebar
Comment 1 User image John Hammink 2011-11-11 15:08:04 PST
Confirmed on Android 3.1  (Samsung Galaxy Tab 10.1);
and Android 3.2  (Asus Transformer)

confirmed one reopened bug in the process:
https://bugzilla.mozilla.org/show_bug.cgi?id=697773
Comment 2 User image Brian Nicholson (:bnicholson) 2011-11-11 16:14:16 PST
Created attachment 573954 [details] [diff] [review]
patch

Looks like there was a typo in Tab.java.
Comment 3 User image Brian Nicholson (:bnicholson) 2011-11-14 14:50:11 PST
http://hg.mozilla.org/projects/birch/rev/a81f3461217f
Comment 4 User image Catalin Suciu [:csuciu] 2011-11-16 02:29:35 PST
I verified this and noticed that the bug is fixed for getfirebug.com and docs.python.org but for cnn.com the favicon is still missing. 
Is this related to this bug? If not, please close this one and I will file a new bug.
Comment 5 User image Brian Nicholson (:bnicholson) 2011-11-17 12:41:37 PST
I can't reproduce this for cnn.com.  It's also possible that your problem is related to bug 701839.  If neither of these fix it, go ahead and file a new bug.
Comment 6 User image Catalin Suciu [:csuciu] 2011-11-20 23:34:37 PST
I cannot reproduce the cnn.com favicon issue on the latest fennec native build:
Mozilla/5.0 (Android;Linux armv7l;rv:11.0a1)Gecko/20111120 Firefox/11.0a1 Fennec/11.0a1

Closing.

Note You need to log in before you can comment on or make changes to this bug.