Closed Bug 701834 Opened 8 years ago Closed 8 years ago

Missing favicons for some sites

Categories

(Firefox for Android :: General, defect, P2)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox11 --- fixed
fennec 11+ ---

People

(Reporter: davehunt, Assigned: bnicholson)

References

()

Details

(Whiteboard: [testday-20111111])

Attachments

(1 file)

I noticed that a few sites aren't displaying favicons. The common factor is that the rel attribute for the <link> is 'shortcut icon' rather than just 'icon'.

Steps to reproduce:
1. Load getfirebug.com or docs.python.org

Expected result:
Favicon is displayed in the awesomebar

Actual result:
No favicon is displayed in the awesomebar
Assignee: nobody → sriram
Assignee: sriram → bnicholson
Confirmed on Android 3.1  (Samsung Galaxy Tab 10.1);
and Android 3.2  (Asus Transformer)

confirmed one reopened bug in the process:
https://bugzilla.mozilla.org/show_bug.cgi?id=697773
Attached patch patchSplinter Review
Looks like there was a typo in Tab.java.
Attachment #573954 - Flags: review?(lucasr.at.mozilla)
Attachment #573954 - Flags: review?(lucasr.at.mozilla) → review+
Priority: -- → P2
http://hg.mozilla.org/projects/birch/rev/a81f3461217f
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
I verified this and noticed that the bug is fixed for getfirebug.com and docs.python.org but for cnn.com the favicon is still missing. 
Is this related to this bug? If not, please close this one and I will file a new bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I can't reproduce this for cnn.com.  It's also possible that your problem is related to bug 701839.  If neither of these fix it, go ahead and file a new bug.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
I cannot reproduce the cnn.com favicon issue on the latest fennec native build:
Mozilla/5.0 (Android;Linux armv7l;rv:11.0a1)Gecko/20111120 Firefox/11.0a1 Fennec/11.0a1

Closing.
Status: RESOLVED → VERIFIED
tracking-fennec: --- → 11+
You need to log in before you can comment on or make changes to this bug.