printing long tables paginates oddly

VERIFIED DUPLICATE of bug 66804

Status

()

Core
Printing: Output
VERIFIED DUPLICATE of bug 66804
18 years ago
18 years ago

People

(Reporter: Tim Larson, Assigned: dcone (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Mozilla 0.8 - 2001021508
When printing long tables (that span more than one page) the page breaks are put
in odd places.  At the example URL, the page breaks after the first row (Monday,
Tuesday, etc), leaving most of the first page blank, and forcing some to a third
page.  The content could easily fit on two pages if the page break wasn't so
early.  This also means that content is often separated from headers (as it is
here) because few people make use of THEAD and TFOOT.
(Reporter)

Comment 2

18 years ago
Boris:  Not quite.  Bug 24952 refers to content getting cut off.  I'm not
experiencing that.  I'm just getting the page break in a very poor spot, that
leaves most of a page blank.  

It may be convenient for the algorithm to try breaking at a table row but that's
not convenient for the user.  The nice handling of the page break between pages
2 and 3, which is within a single very tall row, shows that this is possible. 
Mozilla should be able to print the 2nd row of the table beginning on the first
page immediately below the 1st row.

Comment 3

18 years ago
Possibly bug 31544?
(Reporter)

Comment 4

18 years ago
Keyser: Not quite that, either, though I have also noticed that behavior.  Let 
me try some ASCII art of a long table.

  -------------  -
  | first row |   \
  -------------    \            <-- but page break put here  :(
  | tall      |     length of
  | second    |     paper page
  | row       |    /
  |           |  _/
  |           |
  -------------

Because the second row will not fit completely on the first page, the entire row 
is shunted to page two.  This is bad.  It should try to print as much of the row 
2 content on page 1 as is possible.

If one row by itself is too long for a page, it will correctly break that row 
across multiple pages very nicely.  I think the algorithm needs to be changed to 
perform this behavior at all times rather than trying to put a page break 
between rows as a first attempt.
(Assignee)

Comment 5

18 years ago
this is defenitely a duplicate.. 
Karnaze has all these type of table pagination bugs.

Comment 6

18 years ago

*** This bug has been marked as a duplicate of 66804 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
verified in 4/20 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.