Closed Bug 66804 Opened 21 years ago Closed 20 years ago

Printing Pagenation is broken for tables [print] causing top banner to print on separate page

Categories

(Core :: Printing: Output, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla0.9.6

People

(Reporter: burleigh, Assigned: karnaze)

References

()

Details

Attachments

(2 files)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20010127
BuildID:    2001012708

Print page range has an odd way of defining "pages": in the example url (and in
others I've tried), printing page 1 shows the top graphic and perhaps some right
side material; page 2 shows this site's masthead plus an abstract of the article
followed by a page break, then the full text of the article appears on another
printed page; finally, page 3 shows the remainder of the article text plus
bottom material.  In all, separate prints of page 1, then page 2, then page 3,
produces four sheets of paper (HP 8100 PCL6 driver).

www.oah.org reveals similar behavior: the top graphic becomes page 1.

Reproducible: Always
Steps to Reproduce:
1. Visit the URL (either example).
2. Print, Page Range, 1 - 1, then 2 - 2, etc.

Expected Results:  I don't quite know what a "page" is in a web browser.  But I
would think that the page up and page down keys might be a clue.  Certainly this
behavior is different than that of ns4.x.
I'm seeing this also.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nsbeta1
Here ya go.
Assignee: dcone → rods
The url in question has an IFrame. At this time we are not printing iframes or 
framesets correctly (we are working on it). Try it out on a site that doesn't 
have iframes or framesets.

Status: NEW → ASSIGNED
These two pages will exhibit similar behavior:

www.oah.org
www.novell.com/news/leadstories/inthenews.html

In both cases the top graphic (and some left side-matter at the Novell page)
print as page 1.  To get the text, you must print page 2 - 2.

Thanks for the improvements, this is the right direction.
This should be fixed now. When a page prints and the IFrame in the page is not 
printed on that page, that is a different bug, which dcoen should already have
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Frank is this working for you now? please mark verified-fixed...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Thank you for asking.  I just tried two pages, with my first test being to print
the whole page.  As I wasn't able to get past that point, I would have to say
the issue is not fixed.  Here are two test URLs (the second being the original):

http://www.novell.com/news/press/archive/2001/02/pr01012.html
http://www.networkcomputing.com/1202/1202centerfoldtext.html

The Novell page prints four pages: page one is the top graphic, page 2 is the
bottom graphic (copyright, privacy, feedback), and the 3rd and 4th pages have
nothing but a url for ad.doubleclick.com....  None of these four pages contained
any readable text.  Then I tried the original site.  The first page contained
the top banner plus the line with FAQs, Site Map, etc.  The second page showed
the bottom links and graphic.  Again, no text printed on either page.

I am using 2001022605 on win2k.  I'm choosing the "Reopen bug" item.  Hope that
is ok.
I sending this back to dcone who is dealing with printing/iframe/frame issues
Assignee: rods → dcone
Status: REOPENED → NEW
There could be a couple issues here you have to try.  Does the behavior only 
happen when you make a selection, or does it print badly all the time.  There is 
a table bug that pagenation does not work well.. I think you may be hitting that 
one.
Status: NEW → ASSIGNED
Summary: Print page range produces unexpected page definitions → Print page range produces unexpected page definitions [print] [selection]
Target Milestone: --- → mozilla0.9.1
On the way to testing page range printing, I first tested plain "print
everything" printing.  The steps were nothing more than these:
1. load file
2. file menu
3. print, then ok.

That's it.  Hence nothing was selected and I'd only asked it to print the entire
document.  It may be that the title of this bug isn't now useful.
Chris this is a duplicate.. pagenation problem.. can you dup this against the 
bug you are keeping for this.
Assignee: dcone → karnaze
Status: ASSIGNED → NEW
Summary: Print page range produces unexpected page definitions [print] [selection] → Printing Pagenation is broken for tables [print]
Looks like a dup of bug 64447.
I'm not seeing a problem when printing the whole document. Marking worksforme.
Status: NEW → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → WORKSFORME
verified in 4/12 build.
Status: RESOLVED → VERIFIED
I'm sorry, this does not appear to be fixed.  I've just tried it again on build
of 2001041604 on win32 (installed with the installer) and get the same kind of
mess I got to begin with.  Today, I get three pages:
Page one contains the banner material down to and including the links (FAQs,
Site Map, etc);
Page two is blank except for heading and footer
Page three has the left three of four characters of some links to the far right
of the page, nothing to the left.  Then there's some bottom material.

No part of the actual article printed.

If it matters, the print to an HP 8100 took a very long time with the Data light
flashing a lot.

Thanks.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
Status: REOPENED → ASSIGNED
Target Milestone: mozilla0.9.1 → mozilla0.9
I filed bug 76298 for the slow printing problem.
r = bernd looks good to me
sr=waterson
The patch is in.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
Comments from Frank:

 i have just tried printing from the page with these results:
1. the top banner still prints as a separate page.  that isn't correct behavior,
but may also not be
part of this bug.
2. the text of the article does print now.
 
since the top banner still prints on a separate page, i would say that printing
is *not* fixed.  but if
you all regard that as a separate issue, then i would say the bug, "text does
not print," is fixed.
 
Frank, you wanna file a separate bug on the top banner issue
and mark this bug VERIFIIED-FIXED ?

thanks.
*** Bug 70198 has been marked as a duplicate of this bug. ***
There are several open bugs that describe somewhat similar-sounding behavior. 
I'll say this one is fixed, and that the splitting of top matter from page text
and side matter is described in bug 64447, which is not yet fixed.  Thanks!
Status: RESOLVED → VERIFIED
*** Bug 75213 has been marked as a duplicate of this bug. ***
*** Bug 76344 has been marked as a duplicate of this bug. ***
Blocks: 77421
*** Bug 80966 has been marked as a duplicate of this bug. ***
Bug 80966 is not fixed in build 2001051720 so maybe it's not a dupe of 66804
This bug is not fixed, or it has regressed.  Here is a page that shows two bad
behaviors:
- top matter is orphaned on the first page
- article text begins printing on page two but is not complete (the page is full
but the article text does not continue to page 3 as it should).  Page 3 contains
bottom matter.
http://www.zdnet.com/pcmag/stories/reviews/0,6755,2770536,00.html
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Hiya, folks.  I've just printed from this page:

http://support.novell.com/servlet/tidfinder/2958182

and saw that we get just the first page of the article.  I don't know who is
responsible to set the milestone, this one is set to moz 9.  I did set the
severity at critical, since I know in our building people can't use the browser
if it can't print full pages.  Hope this is ok.
Severity: normal → critical
Severity: critical → major
On Win98, 20010719, trying to print http://www.nytimes.com I get the top banner
of the page, plus one small graphic (a little box with an arrow).  Then the rest
of the first page is blank, with the exception of the footer added by the client
(e.g., "1 of 4        7/18/01 10:50 AM").

Pages 2-4 print as expected, as if page 1 had printed properly.  So I lose the
content that should have appeared on page 1.  It does not just get pushed down
to page 2; it's just gone.

I suspect it's table related.

Not sure if this describes the same kind of behavior as others have experienced.
cc: dcone.
Status: REOPENED → ASSIGNED
Target Milestone: mozilla0.9 → mozilla0.9.4
Target Milestone: mozilla0.9.4 → mozilla0.9.5
http://www.zdnet.com/pcmag/stories/reviews/0,6755,2770536,00.html prints with a 
different layout than the browser and there is dataloss. I'll open a new bug on 
that.

On a recent Win2K trunk, I'm not seeing the problem on 
http://support.novell.com/servlet/tidfinder/2958182 or http://www.nytimes.com.

beppe, sujay, there have been a lot of bugs marked as dups of this and some/all 
of them could be dataloss. But the only test case I find is the one I attached 
to this bug and it works just fine. We need a reduced test case, thanks.
Chris, there is an obvious problem with http://www.nytimes.com

I used today's 8/24 build on Win98 and printed that page out. The problem
is that only the top banner prints on the first page(page 1) and the remaining
content prints on the rest of the pages 2 thru 5.

also see bug 79834, same problem here:


using 5/9 build of netscape

1) launch netscape
2) jump to Netscape home page
3) click om Maps
4) enter starting and dest. address
5) Print

the top half of that output(banner and "Map & Driving Directions")
is printing on one page 

and then the driving directions and rest of content are printing
on 2nd page.

they should all printout together.
Chris, maybe that is expected w/ nytimes? the table(content) could be getting
pushed out to the second page?
Sujay -- can you look at the code of the page and see if it is splitting where a 
table starts
assigning qa_contact to amar@netscape.com he's in table/layout qa.
he will work on reduced test case if necessary for this bug.
QA Contact: sujay → amar
In the given Uri www.nytimes.com the header is first table and the body is the 
next table
 When you print the URI by reducing the number of rows in the second table which 
was causing the problem its printing fine.. But if you increase the no of rows 
in the second table it breaks but this time on the second physical page.. 

 According to Beppe the reason might be the logical page contains too much data 
to fit in one physical page...
also http://www.businessweek.com shows the same problem 
in other words, we are not splitting the 2nd table to print on the 1st page and 
instead we are taking the 2nd table and starting to print on the 2nd page
On the chance that the same analysis applies, I want to tell you of an important
site with a moz/ns6.1 printing problem that seems related to tables.

At www.fedex.com you can create and print a waybill / airbill.  It's a one page
document with small and large barcodes, as well as addresses.  We've found on
ns6.1  that a waybill's middle row (which includes the recipient address and the
largest bar code) is just not there when printed with moz/ns6.1.

I've seen a couple of our staff run into this, but I don't myself have a fedex
account--but I'm sure someone there does.  Thanks.
Target Milestone: mozilla0.9.5 → mozilla0.9.6
reassigning to m0.9.6
Summary: Printing Pagenation is broken for tables [print] → Printing Pagenation is broken for tables [print] causing top banner to print on separate page
Blocks: 104166
nominating for nsbeta1. This failure in very common usage is the kind of thing
that could prevent lots of companies from deploying the browser.
Keywords: nsbeta1
The patch fixes the url and I'm marking this fixed again. I opened bug 105166 to 
handle nytimes.com. Sujay, please transfer any other relevant info to bug 
105166.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → FIXED
marking verified...if there are any issues with banner being printed on one page
and content being printed out on rest of pages, please comment in
new bug 105166
Status: RESOLVED → VERIFIED
I forgot to mention that the following works now so this bug can be closed
out...but we still have the nytimes.com issue....see bug 105166

---------------------------------------------------
using 5/9 build of netscape

1) launch netscape
2) jump to Netscape home page
3) click om Maps
4) enter starting and dest. address
5) Print

the top half of that output(banner and "Map & Driving Directions")
is printing on one page 

and then the driving directions and rest of content are printing
on 2nd page.

they should all printout together.
-----------------------------------------------------------------
removing item for this fixed bug from 0.9.6 release notes.
You need to log in before you can comment on or make changes to this bug.