Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Remove checkbox for add-on auto-checking for updates (extensions.update.enabled) from the options window, and make enabling extensions.update.autoUpdateDefault in the add-ons manager also enable extensions.update.enabled.

RESOLVED FIXED in Firefox 11

Status

()

Firefox
Preferences
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: al_9x, Assigned: Steffen Wilberg)

Tracking

10 Branch
Firefox 11
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
https://groups.google.com/group/mozilla.dev.apps.firefox/browse_thread/thread/d302eea559084d34

The options dialog has an "Automatically Update: Add-ons" checkbox.

The add-ons manager has an "Update Add-ons Automatically" check menu.

That these are different settings and how they are different is
unclear.  The first one controls automatic checking and should be titled
something like "Auto check for add-on updates."  The second, controls auto
installation after detection and should be titled something like "Auto
install detected updates."  And ideally, they should appear next to each other.
(Assignee)

Comment 1

6 years ago
Bah, I made the change in bug 600505 (already on Aurora/10), not knowing about the second pref. :-(
Apart from reorganizing the app update pref UI, I did this:
-Automatically check for updates to: Add-ons
+Automatically update: Add-ons

That's misleading as its pref (extensions.update.enabled pref) only toggles *checking* for updates. If it finds updates, it will highlight them in the add-ons manager. It will not even prompt the user (that's bug 591189).

I wonder whether we still need that pref at all. Who would disable it? 
In the rapid release world, wouldn't people at least want to *know* that there's an update (or version bump) available, once they open the add-ons manager?

So we could make this checkbox toggle the pref extensions.update.autoUpdateDefault instead. "Update Add-ons automatically" currently lives in the "gears" menu of the add-ons manager and was introduced by bug 586574. CC'ing folks from that.
Assignee: nobody → steffen.wilberg
Blocks: 600505
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
OS: Windows XP → All
Hardware: x86 → All
Version: Trunk → 10 Branch
(Reporter)

Comment 2

6 years ago
(In reply to Steffen Wilberg from comment #1)
> I wonder whether we still need that pref at all. Who would disable it? 

Yes, you need it.  In some cases you want no checking whatsoever: subjective preference for manual checking, testing/troubleshooting profiles that should not update and issue any unsolicited background traffic, avoiding unsolicited triggering of on-demand dial-up connection, privacy/trust reasons (any app that does not allow one to disable phone home connections is acting suspiciously), etc. 

The purpose of this bug is not to eliminate the auto check pref but to title it appropriately so as to disambiguate it from the auto apply pref.
(In reply to al_9x from comment #2)
> (In reply to Steffen Wilberg from comment #1)
> > I wonder whether we still need that pref at all. Who would disable it? 
> 
> Yes, you need it.  In some cases you want no checking whatsoever

I'd agree we need a pref for it, though I'm inclined to think that we probably don't need it in the main UI anymore.

Either way the update settings are overly complex for the add-ons manager, we need to figure out what use cases we actually want to support and simplify things.
(In reply to Steffen Wilberg from comment #1)
> I wonder whether we still need that pref at all. Who would disable it? 

I believe the history of this was that when automatic add-on update installation was first added and enabled by default, there was some outcry that the check from a user's profile against what add-on updates were available would be potentially identifiable itself.  If this pref is little used at this point, it may well fall under the "the world has changed" category, and simply getting rid of the pref item would be fine.  As far as I know, there's still an about:config items for this (can anyone verify?), and in the rapid-release world I wonder if anyone would really care about add-on update checks when Firefox itself is being updated so often.

So, my 2 cents is with Comment 1 - this pref is relic of Firefox 4 and no longer relevant.  And, with the preference in the add-ons manager to automatically update add-ons, it's also potentially confusing.  Let's simply remove it.

(In reply to al_9x from comment #2)
> (In reply to Steffen Wilberg from comment #1)
> > I wonder whether we still need that pref at all. Who would disable it? 
> 
> Yes, you need it.  In some cases you want no checking whatsoever: subjective
> preference for manual checking, testing/troubleshooting profiles that should
> not update and issue any unsolicited background traffic, avoiding
> unsolicited triggering of on-demand dial-up connection, privacy/trust
> reasons (any app that does not allow one to disable phone home connections
> is acting suspiciously), etc. 

Considering you can turn automatic add-on updating off in preference of manual updating, is there a truly compelling case to include in main preferences the ability to turn off even checking?
(Reporter)

Comment 5

6 years ago
(In reply to Jennifer Morrow [:Boriss] (Firefox UX) from comment #4)
> (In reply to al_9x from comment #2)
> > (In reply to Steffen Wilberg from comment #1)
> > > I wonder whether we still need that pref at all. Who would disable it? 
> > 
> > Yes, you need it.  In some cases you want no checking whatsoever: subjective
> > preference for manual checking, testing/troubleshooting profiles that should
> > not update and issue any unsolicited background traffic, avoiding
> > unsolicited triggering of on-demand dial-up connection, privacy/trust
> > reasons (any app that does not allow one to disable phone home connections
> > is acting suspiciously), etc. 
> 
> Considering you can turn automatic add-on updating off in preference of
> manual updating, is there a truly compelling case to include in main
> preferences the ability to turn off even checking?

You are arguing for dumping just the UI not the underlying pref, right?  As long as the underlying pref remains, loss of the UI is manageable, but I would like to point out that the current confusion can be eliminated without removing the UI.

There is nothing inherently complex or confusing about the concepts of auto checking for updates and auto installing detected updates.  The confusion stems from poor placement and the naming of the settings.  If they were arranged next to each other and named according to what they actually control:

[x] Auto check for add-on updates
[x] Auto install detected updates

as opposed to 2 ambiguous, identically named "auto update add-ons" settings in different locations, there wouldn't be any confusion.
(Assignee)

Comment 6

6 years ago
(In reply to Jennifer Morrow [:Boriss] (Firefox UX) from comment #4)
> As far as
> I know, there's still an about:config items for this (can anyone verify?),
The "extensions.update.enabled" pref is always present in about:config, defaulting to true.

> So, my 2 cents is with Comment 1 - this pref is relic of Firefox 4 and no
> longer relevant.  And, with the preference in the add-ons manager to
> automatically update add-ons, it's also potentially confusing.  Let's simply
> remove it.

(In reply to Dave Townsend (:Mossop) from comment #3)
> I'd agree we need a pref for it, though I'm inclined to think that we
> probably don't need it in the main UI anymore.
OK, will do.

I'd also suggest a change to the "gears" menu of the add-ons manger: If the user enables "Update Add-ons automatically" (extensions.update.autoUpdateDefault), we should also enable the "check for add-on updates" (extensions.update.enabled) pref (in cmd_toggleAutoUpdateDefault), because we can't automatically update without having checked for updates first.
(Assignee)

Comment 7

6 years ago
Created attachment 574654 [details]
screenshot of the options window with the checkbox removed
Attachment #574654 - Flags: ui-review?(jboriss)
(Assignee)

Comment 8

6 years ago
Created attachment 574656 [details] [diff] [review]
patch
Attachment #574656 - Flags: review?(dtownsend)
(Assignee)

Comment 9

6 years ago
Created attachment 574659 [details] [diff] [review]
string removals (for moz-central only)
Attachment #574659 - Flags: review?(dtownsend)

Comment 10

6 years ago
(In reply to Steffen Wilberg from comment #1)
> I wonder whether we still need that pref at all. Who would disable it? 

We deploy various add-ons (Zotero, Zotero OpenOffice plugin, Adblock Plus, the British English dictionary) to all our deployments of Firefox at all our clients, on a system-wide basis rather than a per-user basis. We control when new versions of those add-ons are automatically deployed and so want the ability for people not to be nagged about updates and not to have those updates automatically try to update.
(Assignee)

Comment 11

6 years ago
Sure. Your admin can still toggle those prefs in about:config, I'm just removing the checkbox to do that from the options window.

Comment 12

6 years ago
I am that admin. I just wanted to add an answer to the question "Who would disable it?" because my angle hadn't been covered and it seemed quite a sweeping statement being made by the question, is all.
Comment on attachment 574656 [details] [diff] [review]
patch

Dropping from my review queue until we have agreement from UX on this.
Attachment #574656 - Flags: review?(dtownsend)
Comment on attachment 574659 [details] [diff] [review]
string removals (for moz-central only)

Dropping from my review queue until we have agreement from UX on this.
Attachment #574659 - Flags: review?(dtownsend)
Attachment #574654 - Flags: ui-review?(jboriss) → ui-review+
(Assignee)

Updated

6 years ago
Attachment #574656 - Flags: review?(dtownsend)
(Assignee)

Updated

6 years ago
Attachment #574659 - Flags: review?(dtownsend)
Comment on attachment 574656 [details] [diff] [review]
patch

Review of attachment 574656 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/mozapps/extensions/content/extensions.js
@@ +760,5 @@
>          } catch(e) { }
> +        var newValue = !oldValue; // toggle
> +        Services.prefs.setBoolPref(PREF_AUTOUPDATE_DEFAULT, newValue);
> +
> +        // If trhe user wants us to auto-update add-ons, we also need to

Correct this typo
Attachment #574656 - Flags: review?(dtownsend) → review+
Comment on attachment 574659 [details] [diff] [review]
string removals (for moz-central only)

Review of attachment 574659 [details] [diff] [review]:
-----------------------------------------------------------------

I wouldn't expect these changes to go to aurora at this point anyway.
Attachment #574659 - Flags: review?(dtownsend) → review+
(Assignee)

Comment 17

6 years ago
Changing summary to what the patch does.
Keywords: uiwanted
Summary: "Automatically update: Add-ons" is not a good title for a pref, in light of the preexisting "Update Add-ons automatically" → Remove checkbox for add-on auto-checking for updates (extensions.update.enabled) from the options window, and make enabling extensions.update.autoUpdateDefault in the add-ons manager also enable extensions.update.enabled.

Comment 18

6 years ago
Wouldn't it make more sense to leave the checkbox, but make it toggle exactly the same preferences as that gears menu item? This way, all update-related checkboxes would be kept in one place, and all add-on related prefs would also be available in add-on manager. Having two ways to do something doesn't always hurt IMO.
(Assignee)

Comment 19

6 years ago
Pushed both patches as one changeset, with typo fixed:
http://hg.mozilla.org/mozilla-central/rev/6057abf8f4e6
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 11
(Assignee)

Updated

6 years ago
Blocks: 710064
You need to log in before you can comment on or make changes to this bug.