File MIME-Type (Content-Type) Corruption

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: rtrappman, Unassigned)

Tracking

8 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

7.02 KB, application/octet-stream
Details
(Reporter)

Description

7 years ago
Created attachment 574069 [details]
mimeTypes.rdf

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

Uploaded a file to my online storage site and it notified me that the MIME-Type that Mozilla Firefox had sent was not accurate due to a bug.


Actual results:

The site had automatically detected that it should have been "application/x-msdos-program" not "application/octet-stream" as suggested by Mozilla Firefox. 


Expected results:

Mozilla Firefox should have better MIME-Type detection algorithms, and not rely so heavily on the mimeTypes.rdf file. I have attached mine, which may be triggering this bug.
(Reporter)

Updated

7 years ago
See Also: → bug 332690
(Reporter)

Comment 1

7 years ago
If you notice, even when I attached my mimesTypes.rdf file, it incorrectly assigned "application/octet-stream" instead of "application/rdf+xml".
(Reporter)

Updated

7 years ago
See Also: → bug 473372
(Reporter)

Updated

7 years ago
See Also: → bug 507943
(Reporter)

Updated

7 years ago
See Also: → bug 617473
Summary: File MIME-Type Corruption → File MIME-Type (Content-Type) Corruption
(Reporter)

Updated

7 years ago
See Also: → bug 698265
(Reporter)

Updated

7 years ago
See Also: → bug 428658
(Reporter)

Updated

7 years ago
See Also: bug 507943
Are you still seeing this issue?
Flags: needinfo?(rtrappman)
(Reporter)

Comment 3

5 years ago
No, I haven't seen this issue occur in recent versions of Firefox (ex: 24.0).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(rtrappman)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.