ad-blocking prevents viewing gmail messages

RESOLVED FIXED in Camino2.1

Status

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: phiw2, Assigned: alqahira)

Tracking

unspecified
Camino2.1
x86
macOS
Bug Flags:
camino2.1 +

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Comment 1

7 years ago
each individual message block (in a thread) appears to have the class 'ads'.

offender: div[class~="ads"], on line 850
Blocks: 597808
Flags: camino2.1?
Summary: adblocking prevents viewing gmail messages → ad-blocking prevents viewing gmail messages inside conversations
Created attachment 574116 [details] [diff] [review]
back out the problematic rule

I wasn't seeing this because I almost never have conversations/threads in Gmail, and single messages were fine :-(

philippe and I spent over an hour playing with this, and in the end we decided the best way to fix this bug is to back out the rule from bug 597808 that was blocking ads glennbeck.com and substitute div[id="adsTop"] and "adsBottom" to block the ads there that the problematic rule was blocking.  Given how Gmail is now using that class, just overriding it for Gmail would break other parts of the conversation view.

I think we have to respin for this, unless Google changes the class names quickly :(
Assignee: nobody → alqahira
Status: NEW → ASSIGNED
Attachment #574116 - Flags: superreview?(stuart.morgan+bugzilla)
Actually, I'm seeing this on single-message "threads" now, too, so it must not have rolled out to my account/"my server" until today.
Summary: ad-blocking prevents viewing gmail messages inside conversations → ad-blocking prevents viewing gmail messages

Comment 4

7 years ago
Comment on attachment 574116 [details] [diff] [review]
back out the problematic rule

sr=smorgan

Where are we with the site stuff for 2.1? If we're ready we could just push 2.1 and then follow up with 2.1.1 (this isn't a 2.1 regression, after all, right?) and then do a 2.1.1 shortly after. But if we can respin without disrupting the 2.1 schedule we probably should.
Attachment #574116 - Flags: superreview?(stuart.morgan+bugzilla) → superreview+
(In reply to Stuart Morgan from comment #4)
> Where are we with the site stuff for 2.1? If we're ready we could just push

Close, but not close enough.  I do hope to be done by the end of this week, but we still have to get the ML build packaged, and we may as well have Marcello do it against a build with the fixes for this and bug 654961> 2.1 and then follow up with 2.1.1 (this isn't a 2.1 regression, after all,
> right?)

Nope, we shipped that rule in 2.0.8 :-(

http://hg.mozilla.org/camino/rev/a5f05025fa22

I'll pull this and the other bug over to the minibranch once I'm in a better location.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
http://hg.mozilla.org/camino/rev/a9b120648e7a for CAMINO_2_1_MINIBRANCH
Flags: camino2.1? → camino2.1+
Target Milestone: --- → Camino2.1

Updated

7 years ago
Duplicate of this bug: 703851
Duplicate of this bug: 703997
You need to log in before you can comment on or make changes to this bug.