Replace the horrible default favicon (dotted square and empty) with a nice favicon

RESOLVED DUPLICATE of bug 1074937

Status

()

defect
RESOLVED DUPLICATE of bug 1074937
8 years ago
3 years ago

People

(Reporter: iceberg, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

8 years ago
Posted image New default favicon
User Agent: Mozilla/5.0 (X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

I upgraded to Firefox 8.


Actual results:

In version 8 of Firefox the favicon associated with bookmarks that do not have their own favicon has been changed to ugly and unwatchable favicon. 

Reproducible: always.


Expected results:

Change this default favicon.

I am attaching a favicon suitable to replace this ugly favicon.

Comment 1

8 years ago
I won't even call it a "favicon". It's just a replacement icon. When Mozilla developed FF 8.0, they broke something inside which causing this problem. All favicons worked in 7.0.1 and should work in any future FF versions. These are not add-ons that were created by individuals, they were created by the websites themselves. So I do think Mozilla has the responsibility to fix it and put whatever they took out back.

Comment 2

8 years ago
Just to clarify the obvious:
The dashed square is the new intended default icon that appears if no favicon from the web page is available for whatever reasons. 
I for one like it.
Iceberg's proposal is very similar to the old one. But the intend was to do it new, plain and simple.
That said, this is a discussion probably not suitable for bugzilla.
Blocks: 648668
OS: Linux → All
Hardware: x86 → All
Version: 8 Branch → Trunk

Comment 3

8 years ago
The new "blank favicon" problem is not just with sites that do not have a favicon. It has replaced the favicon for sites that do have one too.  

Is the answer by @Marooned here correct? 
https://support.mozilla.com/en-US/questions/893818#answer-271741

If so, then I think that this needs fixing, more than the style of the "blank favicon", although I agree that the new "blank" looks like an "error" rather than an intended feature.

Comment 4

8 years ago
(In reply to Liz Panton from comment #3)
> The new "blank favicon" problem is not just with sites that do not have

You are in the wrong bug here. Please read bug 701297 (completely) and put your comment there if adequate.

Comment 5

8 years ago
Apologies j.j. - I followed a link from the discussion that brought me to this bug.

Comment 6

8 years ago
I think there's actually a usability concern here.  To me, as to #3 above, the default icon looks like an UI error.  The old "sheet of paper" icon did not suffer from that problem.
Reporter

Comment 7

8 years ago
My patch for favicon square dotted empty.

http://www.divshare.com/download/16432921-be4

Download this file, unpack it, and replace the original file omni.jar with omni.jar present in this folder.
This folder contains 4 files omni.jar, for 4 different users.

Patch for:
1. Linux english language.
2. Linux italian language.
3. Windows english language.
4. Windows italian language.

This patch it is only for Firefox 9.0.0
For future versions hopefully in an official patch.
Reporter

Comment 8

8 years ago
Update patch for Firefox 9.0.1 (see comment 7)

http://www.divshare.com/download/16449778-e85

Comment 9

8 years ago
(In reply to Iceberg from comment #7)
> My patch for favicon square dotted empty.
> 
> http://www.divshare.com/download/16432921-be4
> 
> Download this file, unpack it, and replace the original file omni.jar with
> omni.jar present in this folder.
> This folder contains 4 files omni.jar, for 4 different users.
> 
> Patch for:
> 1. Linux english language.
> 2. Linux italian language.
> 3. Windows english language.
> 4. Windows italian language.
> 
> This patch it is only for Firefox 9.0.0
> For future versions hopefully in an official patch.
Hello Iceberg,
I tried this patch and it worked for the icons but unfortunately it makes the search engines disappear from the search bar and thus I reverted back to the old 'omni.jar' file. I tried it on a Linux system (openSUSE 11.4 Gnome 2.32 DE).

Lastly, as your included readme note did not state where exactly the file should be placed on a Linux system, it should be specified that it needs to be placed in '/usr/lib/firefox' (with root or sudo rights).

Comment 10

8 years ago
By icons I meant the favicons.
Reporter

Comment 11

8 years ago
I have not tested this patch with Gnome, but with KDE, I have not found problems with KDE.
Replace the omni.jar file is not a good solution.
This patch is for expert users, expert users know as use this file.
My patch only wants to be a stimulus for a necessary official patch.
The problem of the favicon deliberately introduced with version 8 is still without a solution. "This is not a problem" the official response, this is not a solution. This patch is a solution, unfortunately not for all users.

Comment 12

8 years ago
Confirming, this is a valid enhancement request. Bug 685059 comment #19 also indicates that something needs to be done here.
Status: UNCONFIRMED → NEW
Component: Bookmarks & History → Theme
Ever confirmed: true
QA Contact: bookmarks → theme

Updated

7 years ago
Depends on: 685059

Updated

7 years ago
Duplicate of this bug: 788475

Comment 14

7 years ago
Actually, using a page icon has some significant issues over using a dotted square.

I've gone into quite a bit of detail on them in Bug 788475 which argues for restoring the dotted square. (Firefox 17 uses the Linux system icon theme's "empty file" icon)

Updated

3 years ago
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1074937
You need to log in before you can comment on or make changes to this bug.