If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash when typing in search bar

RESOLVED DUPLICATE of bug 548571

Status

Thunderbird
Search
--
critical
RESOLVED DUPLICATE of bug 548571
6 years ago
6 years ago

People

(Reporter: Paul Kenyon, Unassigned)

Tracking

({crash})

7 Branch
x86_64
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20111008085652

Steps to reproduce:

Typing a search query in the "Filter these messages... <Ctrl+F>" bar.


Actual results:

Thunderbird crashed.  Sometimes this happens after only two characters, sometimes a few more.  A majority of the time it works, though.


Expected results:

Thunderbird should search okay without crashing.
(Reporter)

Comment 1

6 years ago
My searches are typically in the format ddddd, where d is a digit.  Many of my messages in my Inbox have numbers like this (ticket numbers) in the subject line.  In another folder, Tickets, they are all of that format.

I am going to disable the "search while typing" feature if I can figure out how, and see how this affects the crashes.  Otherwise, this happens for me very, very frequently, and is easy for me to reproduce.

My Inbox has 5000+ messages.  My Tickets folder has 2500+.

There are many other crash reports submitted by me - I can provide those report IDs if they are helpful.

Comment 2

6 years ago
Thanks for taking the time to report this problem!
Please follow the steps on http://support.mozillamessaging.com/kb/thunderbird-crashes and report back here. Thanks!
We need a stack trace or a breakpad crash-id.
Keywords: crash, crashreportid
I think you mean stackwanted :)
crashid is for when a crash ID has in fact been posted, but the stack not added to the bug https://bugzilla.mozilla.org/describekeywords.cgi#crashreportid
Severity: normal → critical
Keywords: crashreportid → stackwanted
(Reporter)

Comment 5

6 years ago
I've got a crash report from https://crash-stats.mozilla.com/report/index/bp-464da2f5-1aa8-4db7-b6bb-29eab2111123.  I have a bunch of others, but wanted to disable all addons and generate a clean one.

I put my computer to sleep a lot.  I wanted to throw this out there just in case it has anything to do with it, but I have sent and read emails since my last sleep when the crash occurred.
Thanks Paul. Can you add relevant parts of your steps to reproduce to bug 548571?
Status: UNCONFIRMED → RESOLVED
Crash Signature: [@ clearHashEntry]
Last Resolved: 6 years ago
Keywords: stackwanted
Resolution: --- → DUPLICATE
Duplicate of bug: 548571
(Reporter)

Comment 7

6 years ago
Sorry in advance if my reply should have been in 548571 - not sure what's proper bug reporting etiquette after it's been marked duplicate.

Basically, all I do is type in a number in the search field.  I think it has to do with the cadence of my typing - I'll type the first few numbers of the ticket, look over to where the number is in another window, then continue typing.  In the middle of me typing it crashes.  There are 2500 messages (sorted by thread) in the mail folder, so that can't help things.
(Reporter)

Comment 8

6 years ago
Oh, I should clarify that it doesn't always happen!  I am unable to predict when it will occur.
You need to log in before you can comment on or make changes to this bug.