right-clicks should NOT collapse/expand/toggle bookmark folders

VERIFIED FIXED in mozilla0.9.7

Status

SeaMonkey
Bookmarks & History
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Claudius Gayle, Assigned: Blake Ross)

Tracking

Trunk
mozilla0.9.7
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This bug was spawned from bug 68842 and Jesse ruderman's observations...

***Overview Description: 

  Right-clicks on (the triangle widget of) folders in the Manage Bookmarks window both
expand/collapse the folder and pop up the context menu, the first item of which is 
always "Collapse". Choosing 'Collapse' then always toggles the state.

***Steps to Reproduce: 

1) Open Manage Bookamarks.

2) Right-Click on the triangle widget of a folder

3) Select 'Collapse'



***Actual Results: 

	The folder state toggles and the popup comes up. Selecting 'Collapse' toggles it
back.

***Expected Results: 

	Just the popup should come up - the triangle shoud ignore the click.
there might be another bug here as I never see the 'Expand' option.

***Build Date & Platform Bug Found: 

2001022708 on Linux RH6 but NOT 2001022113 on MacOS and NOT
2001022105 on Win98. So this is either Linux only or a recent regression
on all platforms.
I think I can do this at the same time as making click behaviour for twisties 
in the sidebar uniform.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.7
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW
(Assignee)

Comment 3

17 years ago
--> me
Assignee: pchen → blakeross
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.6
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Depends on: 73508
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 4

17 years ago
bookmarksliner is landing in --> 0.9.7.
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Assignee)

Comment 5

17 years ago
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.