Last Comment Bug 706327 - Support multichannel (e.g., 5.1) audio
: Support multichannel (e.g., 5.1) audio
Status: RESOLVED DUPLICATE of bug 1073786
:
Product: Core
Classification: Components
Component: Audio/Video: cubeb (show other bugs)
: Trunk
: All All
: P3 normal 32 with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 782507 748144 790458 790459
Blocks: 812900 881092
  Show dependency treegraph
 
Reported: 2011-11-29 17:21 PST by Timothy B. Terriberry (:derf)
Modified: 2016-09-02 06:55 PDT (History)
10 users (show)
rjesup: needinfo? (greg)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Timothy B. Terriberry (:derf) 2011-11-29 17:21:23 PST
Currently we don't support 5.1 audio at all (see bug 521615). However, even if we tried to open a 5.1 output stream and get the channel mappings correct, some platforms (such as Android) will never be able to provide more than 2 output channels. We should add support for downmixing such streams to what the OS actually provides.
Comment 1 Greg Ogonowski 2015-12-14 01:36:07 PST
Many Android devices pass 5.1 multichannel audio through HDMI.
Currently Firefox is now the only major browser not supporting multichannel AAC audio.
Maybe we can get past this problem soon.
We provide high performance high quality streaming audio encoders to many of the largest content providers. We have test HLS streams available upon request. The surround streams unfortunately, play in 2 channels using Firefox. We need multichannel AAC decoding! This would be easy to do now that Firefox is MSE compatible.
Our test multichannel AAC HLS streams currently play using Microsoft Edge, IE for Win 8/10, Safari Mac OS X and iOS, and Google Chrome. It sure would be good to add Firefox to this list.
Please let me know if we can be of assistance to make this happen.
Here are test resources:
https://www2.iis.fraunhofer.de/AAC/
https://www.indexcom.com/products/encoder/
Comment 2 Randell Jesup [:jesup] 2015-12-14 05:11:47 PST
I believe we do support downmixing (for some time now).  We don't support 5.1 through the graph to cubeb output, though, so revectoring this bug to the cubeb portion of that. 

We'd love support for 5.1.  Greg, if you have some cycles to work on patches for cubeb for this, that would help move this feature along, as right no all our audio people are pretty tied up with other work (full-duplex, Worklets for WebAudio, etc).  We can help guide you through the process of submitting patches.  We all hang out on IRC at irc.mozilla.org in #media.
Comment 3 Chun-Min Chang[:chunmin] 2016-08-31 05:32:04 PDT
Hi 
I am interested in 5.1 audio. Could someone give me a hint?
Comment 4 Maire Reavy [:mreavy] 2016-09-02 06:55:24 PDT

*** This bug has been marked as a duplicate of bug 1073786 ***

Note You need to log in before you can comment on or make changes to this bug.