Last Comment Bug 707395 - Remove deprecated PR_ABS/PR_MIN/PR_MAX uses from nsSHistory.cpp
: Remove deprecated PR_ABS/PR_MIN/PR_MAX uses from nsSHistory.cpp
Status: RESOLVED FIXED
[mentor=jlebar][lang=c++]
:
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla11
Assigned To: Thomas Prip Vestergaard [:prip]
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on: 518502 683777
Blocks: 707396 708277
  Show dependency treegraph
 
Reported: 2011-12-02 18:35 PST by Serge Gautherie (:sgautherie)
Modified: 2012-02-01 13:59 PST (History)
5 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Replace PR_MIN/PR_MAX/PR_ABS with NS_MIN/NS_MAX/NS_ABS (2.54 KB, patch)
2011-12-07 08:15 PST, Thomas Prip Vestergaard [:prip]
justin.lebar+bug: review+
Details | Diff | Splinter Review
Bug 707395 - Replace PR_MIN/PR_MAX/PR_ABS with NS_MIN/NS_MAX/NS_ABS (2.61 KB, patch)
2011-12-07 19:49 PST, Thomas Prip Vestergaard [:prip]
no flags Details | Diff | Splinter Review

Description Serge Gautherie (:sgautherie) 2011-12-02 18:35:30 PST
Bug 683777 added these, after bug 518502 removed them from the tree :-/
Comment 1 Thomas Prip Vestergaard [:prip] 2011-12-07 08:15:49 PST
Created attachment 579692 [details] [diff] [review]
Replace PR_MIN/PR_MAX/PR_ABS with NS_MIN/NS_MAX/NS_ABS

I replaced PR_ABS with NS_ABS. Should we do that?
Comment 2 Justin Lebar (not reading bugmail) 2011-12-07 17:38:13 PST
> I replaced PR_ABS with NS_ABS. Should we do that?

Yep.  This looks great!

If you post a new patch with a checkin comment in the form of

  Bug XXX - Replace PR_MIN/PR_MAX/PR_ABS with NS_MIN/NS_MAX/NS_ABS

I'll check it in for you.
Comment 3 Thomas Prip Vestergaard [:prip] 2011-12-07 19:49:59 PST
Created attachment 579950 [details] [diff] [review]
Bug 707395 - Replace PR_MIN/PR_MAX/PR_ABS with NS_MIN/NS_MAX/NS_ABS
Comment 4 Justin Lebar (not reading bugmail) 2011-12-07 20:06:19 PST
Comment on attachment 579950 [details] [diff] [review]
Bug 707395 - Replace PR_MIN/PR_MAX/PR_ABS with NS_MIN/NS_MAX/NS_ABS

Thanks for your patch!

Pushed to mozilla-inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/a6c007e53973

I don't expect this to cause test failures, but you can keep an eye at https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=a6c007e53973

(By the way, it looks like this file had Windows line-endings.  In the future, please submit patches with Unix endings.  You can use the tool dos2unix to convert them.)
Comment 5 Ed Morley [:emorley] 2011-12-08 08:36:24 PST
This has now made it's way to mozilla-central - thanks for the patch! :-)

If you're interested in working on more bugs and need some inspiration, pop onto #developers and say hi!

https://hg.mozilla.org/mozilla-central/rev/a6c007e53973

Note You need to log in before you can comment on or make changes to this bug.