Last Comment Bug 707466 - No tab item is selected after removing last tab in a group outside Panorama (follow up)
: No tab item is selected after removing last tab in a group outside Panorama (...
Status: RESOLVED FIXED
: regression
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: All All
: -- normal
: Firefox 11
Assigned To: Raymond Lee [:raymondlee]
:
:
Mentors:
Depends on:
Blocks: 669694
  Show dependency treegraph
 
Reported: 2011-12-03 13:31 PST by Stefan
Modified: 2016-04-12 14:00 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
v1 (1.29 KB, patch)
2011-12-05 00:47 PST, Raymond Lee [:raymondlee]
ttaubert: feedback+
Details | Diff | Splinter Review
v2 (4.51 KB, patch)
2011-12-07 00:23 PST, Raymond Lee [:raymondlee]
ttaubert: review+
Details | Diff | Splinter Review
Patch for checkin (4.80 KB, text/plain)
2011-12-07 06:34 PST, Raymond Lee [:raymondlee]
no flags Details

Description Stefan 2011-12-03 13:31:54 PST
User Agent:  

Steps to reproduce:

1) Open two groups in Panorama. Each group with one tab.
2) Click on one tabitem
3) In the normal browser mode, 
4) Close/restart Fx.
5) Close the last tab.



Actual results:

No tab item is selected.


Expected results:

A tab item is selected.

Related to 
Bug 705621 - No tab item is selected after removing last tab in a group outside Panorama
Comment 1 Virgil Dicu [:virgil] [QA] 2011-12-04 22:28:47 PST
Mozilla/5.0 (X11; Linux x86_64; rv:11.0a1) Gecko/20111204 Firefox/11.0a1

Confirmed using Stefan's STR.
Comment 2 Raymond Lee [:raymondlee] 2011-12-05 00:47:13 PST
Created attachment 579009 [details] [diff] [review]
v1
Comment 3 Tim Taubert [:ttaubert] 2011-12-05 02:52:16 PST
Comment on attachment 579009 [details] [diff] [review]
v1

Review of attachment 579009 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, thanks! Please add a test for this.

::: browser/base/content/browser-tabview.js
@@ +132,4 @@
>                if (self._closedLastVisibleTabBeforeFrameInitialized) {
>                  self._closedLastVisibleTabBeforeFrameInitialized = false;
> +                win.UI.showTabView(false);
> +                win.UI.setActive(win.GroupItems.getActiveGroupItem());

Please move this to UI.init() and wrap it in 'if (!GroupItems.getActiveGroupItem()) { ... }' if that works.
Comment 4 Raymond Lee [:raymondlee] 2011-12-07 00:23:12 PST
Created attachment 579615 [details] [diff] [review]
v2

I've looked into this and fixed the root cause. Also, added a test.
Comment 5 Tim Taubert [:ttaubert] 2011-12-07 06:11:47 PST
Comment on attachment 579615 [details] [diff] [review]
v2

Review of attachment 579615 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, that fix is obviously much better. Thanks for digging into that!
Comment 6 Raymond Lee [:raymondlee] 2011-12-07 06:34:51 PST
Created attachment 579676 [details]
Patch for checkin

Pushed to try and waiting for results
https://tbpl.mozilla.org/?tree=Try&rev=9f1395703e05
Comment 7 Raymond Lee [:raymondlee] 2011-12-07 10:40:51 PST
Passed Try!
Comment 8 Tim Taubert [:ttaubert] 2011-12-08 06:27:00 PST
https://hg.mozilla.org/integration/fx-team/rev/8d91ee82719c
Comment 9 Tim Taubert [:ttaubert] 2011-12-08 06:27:43 PST
Sorry, didn't mean to mark it as fixed, yet.
Comment 10 Tim Taubert [:ttaubert] 2011-12-08 21:20:36 PST
https://hg.mozilla.org/mozilla-central/rev/8d91ee82719c

Note You need to log in before you can comment on or make changes to this bug.